Spawning Server?

Trying to access Anaconda notebook is generating this error of trying to spawn server.

Spawning server would fail repeatedly and I still can’t get into my environment. Anyone else has run into this?

Hi there! Sorry to hear about that. Could you post the URL from your browser’s location bar in a reply here so that we can track down where that is failing?

this is the url that i used. and it brings me to this

Thanks! We’re looking into it and will post back here as soon as we have a solution.

Could you try again now? It looks like your account had invalid settings due to an issue on our side. We’ve switched your account back to the correct ones, so it should work now – please do let us know here if it’s not fixed, or if it happens again.,

It works now, thank you very much for your help!

Excellent, thanks for confirming!

Hi there! I believe I’m having this exact issue:

Spawn failed: Server at didn’t respond in 120 seconds

Event log

Server requested

Spawning server…

Spawn failed: Server at didn’t respond in 120 seconds

That’s really strange. The URL pattern looks like it’s using the notebook service, but the host it’s trying to connect to is your machine. How did you get to the point where you saw that page?

Oh, that’s interesting. I signed in through this link:

I’ve tried on multiple different machines but I keep getting the same error. Is this something you can investigate? I’ve got an assignment due and I’ve been using this platform to do the bulk of the work. :smiley:

Could you try going back to and then click on the Notebooks link?

Exact same issue I’m afraid. Here’s what I’m getting:

It looks like you have an install of jupyter-core in your .local directory that is throwing getting involved when we try to start your server and then throwing an error. Would it be ok with you if we uninstall it to see if that helps?

Yes please, that would be great!

Thanks! Could you try accessing it again now? If it works, we’d really love to know how your account got into that state. There’s obviously a bug on our side – changes that you make should not stop the service from starting up for you – but there’s also a separate question of how that package got installed for you. Is there perhaps something in our documentation or tutorials that tells you to run “pip install juptyerlab” or something similar?

Spawning server failed. Please help!

Can we take a look at your files? I’m wondering if you have also somehow got an install of the core jupyterhub classes in your home directory that is overriding the system one. If we can look, and we do find one, do you mind if we remove it? We’d also be interested in knowing how it got there – did you use the “pip” command to install anything?

Please remove it to make it work. I did install anaconda on my main laptop (used the installer), however the same error is on other systems too (where anaconda is not installed).

Please do the required thing, as I am unable to work on the notebooks from several days.

Do you have an update on this? I really need to get access today, if possible.