Not able to install packages properly

I tried to install several python packages / libraries on my fedora 38 machine.
Installation seems to function. But I’m not able to “access” the packages in PyCharm, for example.

Could this be somethin about the virtual environment?
→ Think Python stuff is preinstalled on fedora.

Perhaps this is off-topic, sorry.

I tried the installtion with “pip install” and also in the IDE.


You likely need to configure Pycharm itself to use your preexisting conda virtual environments.

Hae you already tried what is mentioned in this document?

Thanks. I think i kind of messed up those things.
I just installed anacond freshly and made the env like described.
Now it’s ok.

But i wonder why my Anadonda Environment is (i) in /root/Anaconda (?) first, and (ii) why my fedora machine does not recognize the Anaconda Stuff.
It’s really strange (at least for me). I had to install conda as well as spyder via PackageManager. I’m not able to launch anaconda-navigator nor spyder via console. When i install Spyder from manager separately and / or via discover, it had functioned (see my other issue…). But it seems like Anaconda is at least installed, the dir is there → i put in in home/name/ now. But i can’t really use it in some “normal way”. Also, my “conda-command” must be installed separately via packagemanager. i think this is kind of strange and perhaps i messup up some things with my installation process → which was kind of random, i must say.

So, thank you for your help with this issue. If you have a last hint for the described issue, it would be great. otherwise, i will just use the stuff like this.

→ Problem is, that i have installed Anaconda, but I’m not really able to use the commmon Sypder stuff, which would be nice. I tried to launch Navigator to launch Spyder after that. But this did not work. And me preinstalled spyder is crashing by launch.

Kind Regards


Can you tell me what version of Fedora you are running?

How did you install Spyder? Did you install it from the conda-forge channel? I would give that a try.
There was a problem with an earlier version of spyder that can lead to issues.

Hey. Sorry for the late answer.

I’m on Fedora 38 now, soon 39.

I think this should not be a problem till now. I use Pycharm now with virtual environments or my conda environments and normally it functions good. Not even using Spyder anymore. And installing Jupyter Lab directly in my env and then installing stuff / packages in this env seems to be good too.

Thanks for you help. we can close this ticket.