Failing to add Pycharm CE path in Anaconda preference panel

Hello beautiful people,

I am a beginner & want to link Pycharm CE path into anaconda, so that Pycharm can be run directly from the anaconda-navigator home page.

steps followed:

  1. downloaded pycharm-community-2022.1.2.tar.gz from Download PyCharm: Python IDE for Professional Developers by JetBrains.
  2. extracted the package within the /home/roy/anaconda3/00.pycharm-CE/pycharm-community-2022.1.2 folder
  3. located the pycharm.sh executable file in the location /home/roy/anaconda3/00.pycharm-CE/pycharm-community-2022.1.2/bin/pycharm.sh
  4. verified the file by running /home/roy/anaconda3/00.pycharm-CE/pycharm-community-2022.1.2/bin/pycharm.sh in terminal
    till now pycharm works fine & pycharm is opening.

the problem arises in the below steps
5. adding the pycharm location in anaconda-navigatoir File> preferences>pycharm CE path>
6. putting /home/roy/anaconda3/00.pycharm-CE/pycharm-community-2022.1.2/bin/pycharm.sh in the path > apply
7. after refreshing anaconda navigator homepage no CE edition is shown, also the path is automatically reset to BLANK.
8. also manually added the pycharm PATH using “Configure navigator” option. it is also resetting to blank.

cannot add pycharm CE into anaconda-navigator. any help is much appreciated. screenshot attached for reference.
any help is much appreciated.

system config:

Linux

OS: Ubuntu 18.04.6 LTS x86_64
Kernel: 5.4.0-117-generic
Uptime: 2 days, 1 hour, 41 mins
Packages: 3922
Shell: bash 4.4.20
Resolution: 1366x768
DE: GNOME 3.28.4
WM: GNOME Shell
WM Theme: Nordic
Theme: Nordic [GTK2/3]
Icons: Tela-circle-dark [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i5-3450S (4) @ 3.500GHz
GPU: NVIDIA GeForce GT 710
Memory: 7699MiB / 15973MiB

1 Like

from ktsh.tanka.2020 to biplab.mechatronics

Nice to meet you.
The following settings are PycharmCE settings installed on Fedora Linux 36.

PycharmCommunity path /opt/pycharm-community-2022.1.2

The cause is that you have Pycharm installed in the anaconda directory.

Since Pycharm is managed by JetBrains, it is not included in the components of the component architecture based on C4model, which is Anaconda’s architecture.

That is, it is not included in Anaconda’s registry and will be automatically deleted.

The solution is simple: install Pycharm in / opt or / usr / local and link its settings.

That way, it can coexist with Ubuntu’s Python.

Regards, you.
ktsh.tanaka.2020

1 Like

hello @ktsh.tanaka.2020

Thanks a lot. your solution worked like a charm. putting PyCharm CE into the /opt folder and conda-navigator instantly recognised the pycharm package. screenshot attached.

Should I need to do any further steps to better integrate pycharm with conda, so that pycharm starts with selected conda env automatically?

Regards,
Roy.

1 Like

This question is based on a Linux install, but I’ll add here for posterity that it works for Windows as well.

I like to install apps in particular directories (not the Windows default), and I was struggling to get PyCharm CE to show up as a pane in navigator. This post provided the clue I needed. I reinstalled, let the system put PyCharm in the default location, and it popped right up on Navigator.

This is dumb and frustrating - the Anaconda team needs to fix this (so that the app can be installed anywhere and still work), or update documentation to indicate that Anaconda is looking in the default locations.