Update disaster again

Each time I am sent a message by Anaconda that a new version is available I update my version of Anaconda and it ALWAYS destroys my current version forcing me to reinstall windows and start all over again. If the update does not work properly why is it even released?

Please note I am using Windows 11 on a new Acer Swift X 14.

I use the conda update --all command and what ends up happening is when I open the navigator the next time after the update, I have 100 packages showing up in my environment and I am unable to install anything in a new environment that I create.

Can anyone please provide guidance on why this may happen and how to correct it without having to wipe out windows entirely and having to start from scratch and also can someone explain how Anaconda is tested before these releases because I am using a popular platform in Windows 11.


Hi, It’s possible that you are installing packages inside the base environment, It’s correct to upgrade it but It’s strongly advisable to use environments, you can learn more about environment management on this link:


Thanks Carlos. Do you happen to know why Anaconda does not communicate anything to users other than a new version is ready. For example, it does not state that the update may crash the entire Anaconda navigator and all environments. There is no warning provided when the update message is posted. Also, is this not tested sufficiently? or is it an “Update at your own risk”? Because if it was worded in this way or a way that informed end users that an update my destroy all of your environments, end users might approach updates differently.


Also what does one do when the entire system is now unable to operate. No environment is able to open and no package is able to be installed? Is this really good enough of a solution?


my jupyter notebook is not working suddenly don’t know what happened onely this error showing

please someone help me for this

Thanks for reaching out, It seems that something went bad in the installation process, let’s try a reinstallation but with a full cleaning process this time:

Full Uninstall

A full uninstall removes all traces of the configuration files and directories from Anaconda and its programs with the anaconda-clean program (skip this and go to the Simple remove instructions if you can’t do this).

  1. In Windows, open Anaconda Prompt. In Mac or Linux, open your terminal application.
  2. Install the anaconda-clean package:

conda install anaconda-clean

  1. Then, run anaconda-clean. Run the command by itself to remove all Anaconda-related files and directories with a confirmation prompt before deleting each one, or use the --yes argument to remove all those files and directories without being asked to confirm each one.

If you want to confirm each file and directory you are deleting


If you don’t want to be asked about each file and directory

anaconda-clean --yes

anaconda-clean creates a backup of all files and directories that might be removed in a folder named .anaconda_backup in your home directory. Also note that anaconda-clean leaves your data files in the AnacondaProjects directory untouched.

Simple remove

  • After using anaconda-clean, follow the instructions in Simple remove to finish uninstalling Anaconda Distribution.
  1. Open the file explorer.
  2. Delete your anaconda3 folder in your user folder.
  3. Open Add or remove programs and uninstall your Anaconda installation or your version of Python.

After that you can reinstall Anaconda again and the problem should be fixed, let us know if it worked, we are eager to help.

Thank you for replying i done these all steps but it not worked after that i changed the path while reinstalling and its worked