No updates for Anaconda.Navigator and conda


I have installed Anacoda.Navigator 2.5.0 since fall 2023. In contrast to successfully installed updates in the past, the latest versions 2.5.1 to 2.5.4 can’t be installed any more. I always receive the request to update Anacoda.Navigator to the current version when launching the tool. At update start the “waiting scroll bar” endlessly moves around but no update occurs (no data arive from the internet connection).

Actions taken so far:

Review of documentation at
The described effect isn’t listed.

Update of the navigator-updater to current version 0.4.0 in the base environment:
No influence on the described effect.

Manual update by “conda update -n base anaconda-navigator” through the command line interface (CLI) as described at
Received response in CLI:
Collecting package metadata (current_repodata.json): done
Solving environment: done
==> WARNING: A newer version of conda exists. <==
current version: 22.9.0
latest version: 24.3.0
Please update conda by running $ conda update -n base -c defaults conda
# All requested packages already installed.
Retrieving notices: …working… done
The manual update of conda by “conda update -n base -c defaults conda” in CLI don’t work either. The latest version don’t arrive.

Can you give me some advice for updating anaconda-navigator and/or conda, please?

1 Like

I’m having a problem (maybe related, idk) updating from 2.5.3 to 2.5.4. It started the update, but now it just says “Updating package on root…”. It’s been sitting there for at least half an hour. I’m wondering if I should click on “Dismiss”, or will that screw up my installation?

I wish they’d test their updates a little more carefully before releasing them. This isn’t the first time I’ve had a problem.

Good morning,

Thank you so much for contacting us, you can use this command instead:

conda update --all

The changelog is not updated.

And what is meant by “removing transformers”
I miss some hints or a link to read more about.
Is it meant, that “from transformers import BertTokenizer, BertModel” does not work anymore?

I have difficulties to understand:

Why we have not two update options:

“Update Anaconda”
“Update all related packages and python for Env…”

Why we must use a terminal with commands?

Hello Carlos_Valin,

Thank you for your answer!
I executed the command conda update --all in a terminal of the base environment giving the following 2 results:

I got Anacoda.Navigator version 2.5.4. When launching Anaconda I don’t get an update request any more. So let’s hope that future updates of Anaconda.Navigator will work normally without such a huge update with “conda update --all”.

My former conda version 22.9.0 is still present. The command “conda update --all” didn’t update it to the current version 24.3.0. The still recommended update command “conda update -n base -c defaults conda” don’t change the situation.
Unfortunately the former general conda update may have introduced an incompatibility into the base environment. While trying to update conda to the current version I get the warnings:

Solving environment: -
Warning: 2 possible package resolutions (only showing differing packages):

  • defaults/noarch::ipywidgets-7.6.5-pyhd3eb1b0_2, defaults/win-64::jupyterlab_widgets-3.0.10-py39haa95532_0, defaults/win-64::widgetsnbextension-3.5.2-py39haa95532_1
  • defaults/noarch::jupyterlab_widgets-1.0.0-pyhd3eb1b0_1, defaults/win-64::ipywidgets-7.8.1-py39haa95532_0, defaults/win-64::widgetsnbextension-3.6.6-py39haa95532

I don’t know how severe this may be.

Can you give me some advice for updating conda to the current version?

Thanks for reaching out, It seems that something broke the base environment, let’s try a reinstallation but with a full cleaning process this time:

Full Uninstall

A full uninstall removes all traces of the configuration files and directories from Anaconda and its programs with the anaconda-clean program (skip this and go to the Simple remove instructions if you can’t do this).

  1. In Windows, open Anaconda Prompt. In Mac or Linux, open your terminal application.
  2. Install the anaconda-clean package:

conda install anaconda-clean

  1. Then, run anaconda-clean. Run the command by itself to remove all Anaconda-related files and directories with a confirmation prompt before deleting each one, or use the --yes argument to remove all those files and directories without being asked to confirm each one.

If you want to confirm each file and directory you are deleting


If you don’t want to be asked about each file and directory

anaconda-clean --yes

anaconda-clean creates a backup of all files and directories that might be removed in a folder named .anaconda_backup in your home directory. Also note that anaconda-clean leaves your data files in the AnacondaProjects directory untouched.

Simple remove

  • After using anaconda-clean, follow the instructions in Simple remove to finish uninstalling Anaconda Distribution.
  1. Open the file explorer.
  2. Delete your anaconda3 folder in your user folder.
  3. Open Add or remove programs and uninstall your Anaconda installation or your version of Python.

After that you can reinstall Anaconda again and the problem should be fixed, let us know if it worked, we are eager to help.

Hello Carlos,

Thanks for your comprehensive process description!
When starting with Anaconda 3 years ago, I considered Anaconda’s recommendation and generated my custom environment for my project work. I left the base environment as it has been from the first installation.
In the meantime I installed a number of packages into my custom environment according to my needs. It should be clear that I don’t want to repeat all these installations after having removed and reinstalled the complete Anaconda tool.

I generated a backup from my custom environment and got a small text file (extention: .yaml, size: 11 kB) containing channels and dependencies.
Will this file be sufficient for a restore of my custom environment, when the latest Anaconda tool will have been installed?

Hi again,

Yes that would be enough, in case you have any doubts you can take a look at our official documentation here:

Thank you so much for contacting us.

Hello Carlos,

I executed the procedure (Full Uninstall …) which you described on April 4:

  • It all worked fine: I got the latest versions of navigator and conda in the base environment.
  • I could restore my former custom environment called “NeuralNetwork”

There is only one item left:
I’d like to get the latest versions of the packages in my NeuralNetwork environment, e.g. notebook (v 7.0.8) and numpy (v 1.26.4) as being present now in the base environment.

Executing the command “conda update --all -n NeuralNetwork” in a terminal resulted in former package versions than expected, e.g. notebook (v 6.5.4) and numpy (v 1.24.3). Something blocks the update process to the latest versions in the NeuralNetwork environment.
The same is true when trying to update individual packages in the Navigator GUI (blue arrow pointing to upper right). I get the indication “All requested packages already installed”.

Could you give me a hint, how to address this remaining issue, please?

Hello Carlos,

Here some additional results concerning the unexpected lower package versions being reported in my last post.

I could upgrade notebook to 7.0.8 by selecting this version in the Navigator GUI > Environments > NeuralNetwork > notebook > Right mouse-click on green checkbox > 7.0.8 > Apply >…
I can’t say why the CLI command “conda update --all -n NeuralNetwork” didn’t manage that.

The same attempt don’t work for later versions of numpy, pandas, keras and tensorflow. In these cases there is a conflict with the installed python 3.8.18. Here the report for tensorflow:

LibMambaUnsatisfiableError: Encountered problems while solving:

  • package tensorflow-2.10.0-mkl_py38ha5c4042_0 requires tensorflow-estimator 2.10.*, but none of the providers can be installed

Could not solve for environment specs
The following packages are incompatible
├─ pin-1 is installable and it requires
│ └─ python 3.8.* , which can be installed;
├─ tensorflow-estimator 2.6.0.* is requested and can be installed;
└─ tensorflow 2.10.0 is not installable because there are no viable options
├─ tensorflow 2.10.0 would require
│ └─ python 3.10.* , which conflicts with any installable versions previously reported;
├─ tensorflow 2.10.0 would require
│ └─ python 3.7.* , which conflicts with any installable versions previously reported;
├─ tensorflow 2.10.0 would require
│ └─ tensorflow-estimator 2.10.* but there are no viable options
│ ├─ tensorflow-estimator 2.10.0 would require
│ │ └─ python >=3.10,<3.11.0a0 , which conflicts with any installable versions previously reported;
│ ├─ tensorflow-estimator 2.10.0 would require
│ │ └─ python >=3.7,<3.8.0a0 , which conflicts with any installable versions previously reported;
│ ├─ tensorflow-estimator 2.10.0 conflicts with any installable versions previously reported;
│ └─ tensorflow-estimator 2.10.0 would require
│ └─ python >=3.9,<3.10.0a0 , which conflicts with any installable versions previously reported;
└─ tensorflow 2.10.0 would require
└─ python 3.9.* , which conflicts with any installable versions previously reported.

Pins seem to be involved in the conflict. Currently pinned specs:

  • python 3.8.* (labeled as ‘pin-1’)

I don’t know why python is pinned to 3.8.18. There is no file “pinned” in the folder “C:\Users\user name\anaconda3\envs\NeuralNetwork\conda-meta”. When I installed tensorflow 2.3.0 in the NeuralNetwork environment 2…3 years ago, I had to choose a python 3.8.x to get tensorflow run.

Now I’d like to use a later version of tensorflow and the other important packages as given above.

  • Is there a possibility to unpin my old python version?
  • Other suggestions?

Hi again,

One option to consider is creating a new conda environment with a newer version of Python (e.g., Python 3.9) and installing the necessary packages there. By doing this, you can prevent any conflicts with the fixed Python version in your current environment.

Alternatively, you could manually install the conflicting packages (such as tensorflow, tensorflow-estimator) using pip in the environment. Sometimes, this method can resolve dependency issues that conda might struggle with. Just ensure that the versions you choose are compatible.

You might also want to update the packages in the environment one by one instead of simultaneously updating all with the --all option in the conda update command. This approach could potentially help in dealing with package conflicts more efficiently.

Hello Carlos,

I chose the first option listed above and got Python 3.11.8 installed in the new environment. With this Python version the package tensorflow 2.10.0 (listed on the environments tab “Not installed”) couldn’t be installed. Following up the various LibMambaUnsatisfiableError messages I selected Python 3.10.14 for downgrade.
After the downgrade I could install all required packages and I got the latest versions as formerly listed on the tap “Not installed”.

Great, the issue is closed for me. I didn’t find a button the mark the issue as being closed. If you have the possibility, please do so.

Thank you very much for your assistance!