Random highlights in ipynb code cells

These random highlights in my .ipynb files in Anaconda cloud are driving me bananas. How do I get rid of them?

OH. It’s doing a grammar check. Setp should be Step, and the highlighting goes away. Duh! The other stuff are just things not in its little dictionary.



This is a default JupyterLab feature so not one that we’d have to look into disabling fully.

A couple of things you could try by manually overriding the JupyterLab settings.

Click Settings → Settings editor

Search for “Spellchecker”

Edit the Theme there to use the dotted underline, as it’s a bit less intrusive. You can also untick “Check spelling in comments”, and then try editing some of the other parameters in there until you’re happy.

I’ve noticed it’s only actually checking comments or Markdown cells, so that’s worth remembering too.

I’ll continue to look into this next week and see if we can find a way to fully disable it.


Agreed that this is very annoying.

Two other possible solution in Settings->Settings editor->Spellchecker:

  • Delete all entries in “MIME types for files/editors for which the spellchecking should be activated”
  • Set the " Time delay before spellchecking starts" to be arbitrarily huge