Installation Problem: Error Loading Python DLL

Installing Anaconda3-2022.05-Windows-x86_64 on a home computer running Win7 (have r/w access to all folders). The installer reported “Failed to create menus”, so I looked at the details and found a bunch of “Error Loading Python DLL” messages.

I tried:

  • installing “for all users” as well as “myself” (I’m the only user of this computer)
  • installing using “Run as Administrator”.
  • pruning bad entries in PATH
  • installing in the default location as well as onto my D: drive (I prefer to keep C for just OS)

Saw a bunch of suggestions for the same problem on Stack Overflow. Some seemed ridiculous. None worked.

I confirmed that the installer created the folder C:\Users\p\AppData\Local\Temp\nsnE30E.tmp, but did not create the folders C:\Users\p\AppData\Local\Temp_MEI*.

I saw one other message like this one on the forum, but the only suggestion was “Contact your admin”. This is my home computer, so I’m the admin.

I’m still not 100% sure if Anaconda installed correctly, modulo the system menus. I can recreate menus by hand, no problem, but obviously, that’s pointless if Anaconda itself didn’t install correctly. Where is the anaconda navigator executable located?

anaconda error

1 Like

dear Peter_Salzman.

thank you for your posting.
It is a very disappointing announcement, but python does not work on windows7 unless it is 3.8 or earlier.

So even if I try to install python3.9, I get an error. To solve this problem, you have to upgrade windows to 8 or choose anaconda version earlier than anaconda3-2020-11.

Please look at, detailed tips for each
Python URL: Python Releases for Windows |
anaconda URL: Index of /

Regards, you.

1 Like

Dear Tanaka-san,

That is extremely disappointing, but it’s still better than not knowing why it doesn’t work, so thank you VERY much for letting me know!

I have an X client on my Window box, so I’ll install this on my Linux box and use it over remote X. Not ideal, but it should still work well.

Thank you again, Tanaka-san!