How do update to newer version of Spyder than 5.1.5?

I am running the 2022.05 Windows distribution. The debugger in Spyder does not work for me and this seems to be reported for a long time (since March or April?). I just tried updating from the distribution Spyder 5.1.5 to anything newer. I see on the Anaconda site that version 5.3.3 is available, but when I tried: “conda install -c anaconda spyder” it reinstalled the current version 5.1.5. I tried explicitly installing the latest version by commanding “conda install spyder=5.3.3” it kept spinning and saying it could not solve and never installed anything.

This is an old problem so I know people have solved. Is there a simple way to do the Spyder update?

David

I’ve got the same issue. Seems a little crazy. Spyder 5.1.5 is essentially unusable but Anaconda fails to upgrade to 5.3.3 so the entire Anaconda distro is essentially broken out of the box.

I agree, it is crazy for a major product to have a broken debugger for 4 or 5 months, but I was looking for an easy fix. I do see various discussions, but thought I would get a more direct answer on the company board. My system is a Windows 10 and I am hoping there are some other parameters I can put in the conda command line to do the install.

I’ve got it working now.
Try this:
Uninstall Spyder
Update Anaconda
Fresh install of Spyder (From Anaconda)

1 Like

Steve,
When you say “update” I am unclear what you did. Do you mean go download and run the windows installer (Anaconda3-2022.05-Windows-x86_64.exe)? I just downloaded it and it has exactly the same number of bytes in the file (as the download from May 11).

David Lees
From Pixel 6 Pro

Open the cmd prompt though Anaconda Navigator. Type: conda update anaconda

Thanks Steve, I am trying it now. So I am issuing the following 3 commands:

conda uninstall spyder
conda update anaconda
conda install spyder

David Lees

Steve,
I appreciate your help.

The good news is that I now have a working Spyder 5.3.3

The bad news is that the “conda update anaconda” does not run and gives an error: PackageNotInstalledError: Package is not installed in prefix

And when I went to run something, matplotlib was not installed. But, I installed it and a test code using numpy and matplotlib works. So hopefully all is well.