Conda problems - Macbook Pro Intel Ventura 13.4

I have trouble installing anaconda properly, though in the past it was fine and strightforward. I cannot do conda update for example. Kernel sare not formed if I manage to create env at all. I tried different types of anaconda installations.
after installation when I tried the ‘conda update conda’ , I got:
collecting package metadata (current_repodata.json): failed

>>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
  File "/Users/yaeltsa/anaconda3/lib/python3.10/site-packages/conda/gateways/repodata/", line 161, in conda_http_errors
  File "/Users/yaeltsa/anaconda3/lib/python3.10/site-packages/conda/gateways/repodata/", line 127, in repodata
  File "/Users/yaeltsa/anaconda3/lib/python3.10/site-packages/requests/", line 1021, in raise_for_status
    raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 404 Client Error: Not Found for url:

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/Users/yaeltsa/anaconda3/lib/python3.10/site-packages/requests/", line 971, in json...

Also packages were not recognized outside the base env.