Current_repodata.json Seems to be Missing From Anaconda Packages

I am seeking to update my Python version to 3.10. In the command prompt, when I run conda install python=3.10 I receive a CondaHTTPError: HTTP 000 CONNECTION FAILED for url https://repo.anaconda.com/pkgs/main/win-64/current_repodata.json. When I navigate to the directory https://repo.anaconda.com/pkgs/main/win-64/, however, it appears that current_repodata.json does not exist. There is a file entitled “repodata.json” that I imagine should be the target. Would anyone know if this is: 1.) an issue on the Anaconda end that requires updating the file names in the Anaconda win-64 directory, or 2.) an issue that I can fix locally by changing the file path that is called by ‘conda install python=3.10’ (and how?) or 3.) some other fix I haven’t considered? Thanks so much.

Conda info
conda version : 4.12.0
conda-build version : 3.21.6
python version : 3.9.7.final.0
virtual packages : __cuda=11.4=0
__win=0=0
__archspec=1=x86_64
platform : win-64
user-agent : conda/4.12.0 requests/2.26.0 CPython/3.9.7 Windows/10 Windows/10.0.19042

It may have been a temporary outage. I am able to resolve https://repo.anaconda.com/pkgs/main/win-64/current_repodata.json successfully even though it is not listed in the directory index.
Are you still seeing this problem?

Hi Crystal,
Thank you so much for your response! I honestly had not checked the full address before, but I can resolve it in my browser. That makes me think the issue might be related to the network configuration, so I’ll redouble efforts to solve the problem from our side.

Hi Crystal,

Just a quick update: it was an issue with our company’s firewall, and I have now been able to retrieve the package. Thank you again for looking into this question on my behalf.

Sincerely,

mbranham

1 Like

Hello, I have the same issue. i suspect also my company network settings / firewall. What was changed for you to have it work please ? i’m looking for a solution since so long … thx

Hi Maud, I am not a very sophisticated information technologist, but here are the things that helped me:
(Fetching Conda Packages Behind a Firewall)
I also believe you can temporarily disable ssl verification from your command prompt to download the package using: conda config --set ssl_verify no, then you can re-enable with conda config --set ssl_verify yes. It sounds like the latter approach is unsafe, so be careful pulling from random conda repos.

This issue was resolved for me months ago and I cannot remember which approach was taken, but I believe it might have been that our company’s IT team needed to make a change to my firewall settings. Hope this info is at least somewhat helpful.

Hello,

Thanks a lot for your rapid answer!

I will look into your tips.

Have an nice day,