Cant install anaconda in macOS

i can’t install any Anaconda version in my Mac,I am unable to find the cause, anyone pls help me out

We will gladly help you, Anaconda is compatible with the M2 chip so that wouldn’t be a problem, please try to uninstall Anaconda and install it again, you can download your compatible version here:

I’m going to leave you the installer here for your platform so that you can install it:

There is the x86 installer as well:

It’s also advisable to completely uninstall Anaconda before proceeding with the installation to make sure to get rid of any errors, you can do that if you follow these instructions:

macOS or Linux

  1. Open your terminal application.
  2. Remove your entire Anaconda directory with rm -rf. Depending on your installation, your anaconda2 or anaconda3 directory will be in your root folder or in your opt folder.

The following are a few examples of how you may need to delete your Anaconda folder

rm -rf anaconda3

rm -rf ~/anaconda3

rm -rf ~/opt/anaconda3

  1. Close and reopen your terminal to refresh it. You should no longer see (base) in your terminal prompt.

If you want here is a detailed explanation:

Please let us know if that fixed your problem, we are eager to help you.

@Carlos_Valin my laptop is m1 chip and I have tried every version of anaconda for everything it showing the version is not compatible…


I was getting same error as back ? after deleting anaconda completely I have installed package which u have mentioned but there is no improvement it was throwing same error

Hi again, please try this installer and tell us if that worked for you:

Mac older than 2020:

New Mac (m1,m2 chip) :

Please let us know if that worked for you.

1 Like

I am trying too to install Anaconda on a brand new MacBook Pro equiped with M2 pro chip. I used the installer you mention and this is the message I get

So dissapointed!

Hi Javier,

Thank you for your message, in your case please use this installer:

Please notice that is the last that I posted.

Tell us if that worked for you, we are happy to help.

@Carlos_Valin the second link for installer worked for me…thanks for the help

Thanks Carlos, I thought the later one would be the one to be used. This fix worked also fine for me.

I have a question Carlos. Once I open Anaconda, it immediately suggests to update to version 2.4. Should I accept? or this is precisely the 2023-03 version that did not want to install
? Thanks for you help

There is a work around posted here for the latest build.

Hi Javier, yes you can update it.