Apple M1 - 14.0 (Sonoma) Installation Failures

I’ve been attempting to install the latest version of Anaconda for Mac OS for M1 OS 14.0 (Sonoma) using both the graphical and terminal packages. Both installations fail. Any suggestions?

Did you already have Anacnoda installed and you upgraded to Sonoma or did you upgraded to Sonoma and tried installing Anaconda?

Greetings. I attempted to install Anaconda after I upgraded to Mac Sonoma (v 14.0). I did not have Anaconda installed, nor did I attempt to install Anaconda, on the previous version of the operating system, i.e. Ventura (ver. 13. x).

Did a clean installation of the OS. Anaconda3 installed without problems.

I tried to install anaconda the first time on my MAC M1 (Sonoma 14.0).
I used the package Anaconda3-2023.09-0-MacOSX-arm64.pkg.
Unfortunately the installer says that this package is not compatible with my version of MacOS.
Any ideas?

I had to install using CLI option on my M2


We will gladly help you. Anaconda is compatible with the M1/2 chip so that wouldn’t be a problem. Please try to download and install Anaconda with this link instead:

Please let us know if there is anything else we can do to help!

I have a macbook air m2 running Sonoma 14.0 and I am trying to install it for the first time.

I have the same problem with this link:

as i do with the Anaconda3-2023.09-0-MacOSX-arm64.pkg.


Thank you so much for contacting us, please open your Terminal on the Mac menu and launch these commands:

mkdir /Users/$USER/.config/

mkdir /Users/$USER/.config/fish/

touch /Users/$USER/ .bash_profile .tcshrc .xonshrc .zshrc

touch /Users/$USER/.config/fish/

sudo chown -R $USER ~/.bash_profile ~/.config/fish/ ~/.tcshrc ~/.xonshrc ~/.zshrc

Then proceed with the installation regardless of the output results.
Then you should be able to install Anaconda after a reboot, please let us know if that worked for you.

1 Like

This has worked thank you very much =)

Hello Carlos,

Just to confirm that this fix only allows us to install (

It doesn’t still allow us to install Anaconda3-2023.09-0-MacOSX-arm64.pkg

I have a similar problem installing on a Mac (Sonoma 14.1, Intel).
I tried to follow your instructions, but upon request
“touch /Users/$USER/ .bash_profile .tcshrc .xonshrc .zshrc”
I received an answer
“Permission denied”.

And also if I write this command
“sudo chown -R $USER ~/.bash_profile ~/.config/fish/ ~/.tcshrc ~/.xonshrc ~/.zshrc”
I received an answer
But I can’t write there anything.

What should I do?

I already had Anaconda installed and it failed to launch after installing Sonoma 14.1

Can you provide instructions – for example if I should delete and reinstall, and which package to use?

Thank you.

I’m having the same failure as the initial post here by chiwsox11. I really don’t want to do a kludgy install of an older version of Anaconda. Does anyone know if there are plans in the works to fix this install issue with Sonoma?

UPDATE: I tried the install again, but this time in my user directory instead of Macintosh HD (which I used before) and it appears to have worked. No errors and I’m in Navigator now. I’m running Sonoma 14.1 on a new Mac Studio. The install package was Anaconda3-2023.09-0-MacOSX-arm64.pkg

1 Like

I got same problem too. Mac OS 14.2(Sonama)

I’m having the same installation failures as chiwsox11’s initial post. I’m currently running on macOS Venture 13.6.1

1 Like

During the intallation process, choose install for me only when you get the DESTINATION SELECT. This worked on my M1 Sonoma 14.2.1

1 Like