Cannot connect to Kernel, Anaconda Cloud

Hey, a total newbie here getting started with Python in general. I’ve created a notebook in Anaconda cloud and had success coding with it earlier. However now when I open my workspace I am unable to connect to any kernels and cannot select any. I have no other kernels open and I have sufficient CPU space in my workspace.

Any ideas?

Hi Tatu_Okkonen and welcome to the community.

Have you tried reloading the page, or opening up the notebook service ( in a new browser tab? Sometimes if a tab is left open for a long time without being used, when you return to it, it may be disconnected from the service.

Let me know if that works. If not, we can keep digging to see what may be happening.


Thank you Steve!

I’ve tried to refresh the page, restart my browser and have gone as far as rebooting my PC. Not sure if clearing the browser cache is something to try next…

My internet connection is good and have no issues elsewhere. After multiple attempts I am still unable to see any kernels in the selection menus.


I’m really sorry to hear that. One more question. Can you send the URL that you end up when you launch notebooks? It should be something like<user id>/lab.

If you send that along, I can have the team look into your account and see if something is out of order.

Once again, I’m sorry to hear you’re having trouble and we’ll do our best to get it fixed up quickly for you.


Something else you can look at is the number of running kernels. If you have too many already running, it can cause issues like this. We have a section of the top nav where we display the number of running kernels and JupyterLab has a left panel that can show you them all ( icon that’s a shaded circle with a square in the middle). Try killing a few kernels and see if that helps.

Hi Steve,

I’m having a similar problem (all was working fine yesterday evening, but not this morning): no kernel running and cannot connect to any.
None of the options in “Kernel” menu (“Restart Kernal”, “Reconnect to Kernel” or “Change Kernel”) seem to have effect. In addition, when trying to start a terminal from the Launcher it tells me “bash: fork: retry: Resource temporarily unavailable”. Refreshing, reconnecting to Anaconda cloud does not help either.

Is there any solution?


Hi @tutor.inf4402,

Thanks for reaching out to the community!

Are you able to provide any info about the tasks/code that you were writing last night, as it might help us to debug the issues?

Could you also provide the url your are accessing as it should contain a long user ID that will enable us to dig into the logs of your account and see what went wrong.


Hi Jack,

Thank you for the prompt reply!

Concerning the last night tasks/code, nothing special: some beginner’s level manipulations with lists, trying markdown formatting.
Here is the URL: