Anaconda3 installation fails on MacOS Monterey

I am using the module Spyder 5.1.5 exclusively. Anaconda3 and Spyder 5.1.5 were working under MacOS 11. I then updated my Macbook Pro to 12.0.1 and lost the package PYNPUT. Everything else appeared to be working normally, but I could not find a way to re install pynput. I tried conda install pynput but I got an error.
So then I thought a fresh installation of Anaconda3 might solve the problem. So I deleted Anaconda3 by moving the app to the trash, executed conda-clean, and rm -rf ~/opt/Andaconda3/ and rm -rf ~/Anaconda3/.
After this I kept getting installation failures using the graphical installer. I rebooted the computer numerous times.

Somewhere along the line I lost the “conda” command. I cannot figure out anyway to get it back.
So I installed Anaconda3 using the command line installer. This worked and gave me a working copy of Navigator, but I still have no “conda” command available, and I still have no pynput.

So my questions are:

  1. how to get the conda command back?
  2. how to install pynput in the Monterey OS?
  3. how to trouble shoot the graphical installation failure?

I’m not sure it’s helpful, but this is the reference on the pynput docs: Platform limitations — pynput 1.7.5 documentation

It sounds like you made a successful new install, maybe you need to set paths to find it? Normally, the installer offers to do this for you, or else you might need to put an activate command in your shell startup scripts.

Thank you for the note. It took a while to find the path file that was being used. It was not my local file but in /etc/paths. Once I added the path (/users/username/opt/anaconda3/bin) to that file using a nano editor I got the conda file back.
I am still having trouble with loading pynput, but the security issue with the macs and keyboard monitoring may be an issue.
Thanks for the help.

1 Like