Anaconda Navigator throws error when trying to start PyCharm

Repro:

  1. Install and start Anaconda Navigator on MacBook M1 Pro
  2. Start Anaconda Navigator
  3. On “Home” tab, click “Launch” for PyCharm Professional
  4. Anaconda Navigator throws the error below and PyCharm does NOT start

Has anybody seen this? Any way to fix this?

Thanks,

Dan.

p.s. Anaconda is supposed to be an easy-to-use environment that removes most of the BS with setting up a MacOS development setup. My experience has been the exact opposite.

2022-03-24 18:11:43.975 pycharm[1837:20352] allVms required 1.8*,1.8+
2022-03-24 18:11:43.978 pycharm[1837:20443] Cannot load JVM bundle: Error Domain=NSCocoaErrorDomain Code=3585 “dlopen_preflight(/Applications/PyCharm.app/Contents/jbr/Contents/MacOS/libjli.dylib) => false, tried: ‘/Applications/PyCharm.app/Contents/jbr/Contents/MacOS/libjli.dylib’ (mach-o file, but is an incompatible architecture (have ‘arm64’, need ‘x86_64’)), ‘/usr/lib/libjli.dylib’ (no such file)” UserInfo={NSLocalizedFailureReason=The bundle doesn’t contain a version for the current architecture., NSLocalizedRecoverySuggestion=Try installing a universal version of the bundle., NSFilePath=/Applications/PyCharm.app/Contents/jbr/Contents/MacOS/libjli.dylib, NSDebugDescription=dlopen_preflight(/Applications/PyCharm.app/Contents/jbr/Contents/MacOS/libjli.dylib) => false, tried: ‘/Applications/PyCharm.app/Contents/jbr/Contents/MacOS/libjli.dylib’ (mach-o file, but is an incompatible architecture (have ‘arm64’, need ‘x86_64’)), ‘/usr/lib/libjli.dylib’ (no such file), NSBundlePath=/Applications/PyCharm.app/Contents/jbr, NSLocalizedDescription=The bundle “OpenJDK 11.0.14.1” couldn’t be loaded because it doesn’t contain a version for the current architecture.}

1 Like

Hi Dan,
Thanks for the post and I’m sorry to hear things aren’t working as they should. This sounds a bit like an issue with which PyCharm installer used and which Java it expects. There’s a similar issue posted in the Jetbrains community for another Jetbrains product, where the fix was to use the MacOS Intel installer vs. the Apple Silicon/aarch64 installer.

Just to gather some more information, which PyCharm installer did you use? intel or Apple silicon? For reference, it looks like the installer filename ends in aarch64.dmg for the Apple silicon installer.