Uploading an env file to anaconda.org

I have been struggling to upload my env file to anaconda.org using my command line on mac. After initiating the upload, it asks for my username and password. I believe this is my login credentials for my free anaconda account. After inputing my email as the username and password, it keeps saying the credentials don’t match and those are the exact credentials I use to log into my account. Anyone know how to rectify this?

Great question. There are currently two anaconda sites that can house environments, so you may be using the credentials from one of those sites on the other.

The two sites are:

  • anaconda.cloud : This is the Nucleus site and the same domain as the community forum we’re on now. It is also the location that environments backed up via Anaconda Navigator end up on. This site takes an E-mail and password.
  • anaconda.org : Anaconda.org allows you to upload and host custom conda packages, notebooks, projects, and also environments. You can upload items there via the anaconda command line client. This site uses a separate login that takes username and password.

To solve your issue, first determine which site you signed up for (.org or .cloud). From there:

  • If you have a .org account, use the username and password you signed up with on the anaconda client. Docs are here
  • If you have a .cloud account, use the email and password you signed up with and login in to your Nucleus account via Anaconda Navigator, then back up from there. A quick walkthrough is available here

Hopefully that helps!

Thank you so much. It worked. The account I had was on anaconda.cloud which is why is could not recognise the credentials. I just opened an anaconda.org account now and it worked.


1 Like

I’m having a similar problem. I have an account with both navigator and .org. I can log in find on the web browser but in navigator it doesn’t work. I tried resetting password, etc.
With the .org login attempt it says Httpsconnectionpoolhost=‘api.anaconda.org
I’m running windows 20 enterprise x64
Thanks for your help.

1 Like

dear terman.paul.

thank you for posting.

This error can occur for the following reasons:

This error can occur for the following reasons:

Caused by too many unclosed http connections.

  1. The number of http connections is over the limit and connections are keep-alive by default, causing the server to hold too many connections and not create new ones.

  2. The request speed of the program is too fast.

As a solution

  1. Increase the number of retries The request contains too many connections and the maximum number of retries is exceeded Avoid using persistent connections in the header
  2. Close redundant connections
  3. Upgrade Request

And so on.

Regards, you.