Uninstalling Anaconda

I am new to Anaconda… I am taking a course from Mongodb University which has me downloading and installing Anaconda. In the installation it creates the directory anaconda3…

My issue is that I am stuck getting anaconda to access local host… So… I was going to restart my installation process. To do this I needed to remove anaconda…

I am using a macbook pro running Big Sur version 12.1. I am also using zsh instead of bash. I googled how to remove the program and stack overflow recommend the following command

conda install anaconda-clean
anaconda-clean --yes.

When I run this I get the error: zsh: command not found: anaconda-clean.

Is there any documentation on how to uninstall anaconda so I can reinstall it. I tried to reinstall but the installation program will not complete now that I have ran those commands.

Any help will be really appreciated

1 Like

I’m watching this post because I’ve learned that “uninstalling anaconda” in windows doesn’t really do jack sh!t if you’re trying to remove it as a troubleshooting step. I’m in hell because of a number of undocumented bugs that are supposedly “closed”.

There’s all kinds of files that remain. Be sure to delete what gets installed in %appdata% (Roaming) as well as the base install directory %userprofile%. Make sure you can see hidden folders. Look for .conda and Anaconda3. You might even have stuff in %programdata%. The uninstaller is trash and the “clean” function is also crap.

Thanks… I have gotten absolutely NO help from community… And the website support won’t help. It just points you to the community… I am about ready to slick, my hard drive and start over… It really sucks cause I don’t want to just back this up with my backup feature… I’m really frustrated.

On Windows, anaconda will (by default, if you’ve admin rights) install in C:\Anaconda3. In that folder, there will be a file called uninstall-anaconda.exe.

But I’m not a mac user, so that could be different. According to the documentation:

Open the Terminal.app or iTerm2 terminal application, and then remove your entire Anaconda directory, which has a name such as anaconda2 , anaconda3 , or ~/opt . Enter rm -rf ~/anaconda3 to remove the directory.


Btw, I googled “anaconda uninstall mac os” and this documenation page was the first to show up. I wonder how you first ended up on StackOverflow…