Unexpected behavior from conda: superflous and deprecated

I recently downloaded and installed a clean Anaconda3 distribution to my Ubuntu 22.04 system. I made no changes, no customizations. I previously had a miniconda3 distribution, which I removed completely (\rm -rf miniconda3) before downloading the Anaconda distribution.

Python itself seems to be working just fine, but when I asked conda to update, i.e.,

$ conda update --all

as I have routinely done hundreds of time in the past, I get:

$ conda update --all
Retrieving notices: ...working... done
Collecting package metadata (current_repodata.json): - WARNING conda.models.version:get_matcher(556): Using .* with relational operator is superfluous and deprecated and will be removed in a future version of conda. Your spec was 1.7.1.*, but conda is ignoring the .* and treating it as 1.7.1
Solving environment: unsuccessful attempt using repodata from current_repodata.json, retrying with next repodata source.
`Solving environment: \ failed`

Any thoughts?  Thanks.

Sorry for the lack of detail. This might be useful:

$ conda --version
conda 23.7.4

Also, here’s the name of the file that I used to install Anaconda:


I haven’t solved the problem exactly, but I have things working now. I had previously removed the files from the previous, miniconda3 distribution, but I had neglected to remove all the “hidden” configuration files (~/.anaconda, etc.). I found and removed all that stuff and started from scratch with the full Anaconda distribution. After that, things worked as expected.