TfidfVectorizer(), OpenBLAS and error

Hi all, hoping for some advice. Relatively new to programming so apologies if this is obvious.

I have used TfidfVectorizer() and then tried to run Kmeans on it. I keep getting an error: AttributeError: ‘NoneType’ object has no attribute ‘split’

The code itself works fine on Google Colab so no problem there. I tried all the usual fixes, upgrading OpenBLAS and so on but no luck. A bot said: This error is coming up because get_config() is returning None, and then trying to use the split method on that None return value.

The get_config() function is typically part of the OpenBLAS math library. This error could potentially be caused by an issue with your library files. This appears to be an environment-related issue, not directly related to your Python code.

Possible ways to fix this could be:

  • Reinstalling or updating the OpenBLAS library.
  • Ensuring you have the necessary permissions to access and execute the library.
  • Checking if the OpenBLAS library is correctly installed.

I have tried this and nothing working. Any change anyone knows about this and has a solution?

Thank you in advance. Best wishes, D