Tensorflow environment doesn't work in 2023.03 on Mac

Hi, I used to have 2022 version of Anaconda installed on my Mac, I was able to install then use tensorflow in jupyter notebook without any issue based on instructions : TensorFlow — Anaconda documentation
But after I changed to 2023.03 version and reinstall the tensorflow based on same instructions, then the tf environment can’t find the ‘jupyter’ nor ‘ipython’. Any clues why ? Thx for comments.

Good morning,

Thank you so much for contacting us, please launch these commands:

conda create -n tf tensorflow

conda activate tf

conda install -n tf ipykernel

conda install -n tf jupyter

That should fix your problem, let us know if that worked for you, we are happy to assist you.

So this means I have to re-install all packages I added into the ‘base’ environment in order to use this new ‘tf’ environment ? (should the Anaconda document add some more info there ?)

BTW, I did add all packages, like seaborn, plotly, scikit-learn,… into the new ‘tf’ env, then launch the jupyter notebook from ‘tf’, then things seems working fine ! But I still don’t know why the 2022 version of Anaconda just work after the first two steps (create the ‘tf’, active) then I can launch the jupyter notebook without any issue.

Anyway, thx a lot !

Hi again,

I’m glad that it worked for you, each environment work isolated from the other, I will leave you useful information about environments and Anaconda here:


Don’t hesitate to reach out again if you need anything else, thank you for contacting us!!