Spyder fails to start on new install

I had a previous installation of Anaconda Navigator that I had updated. After that update Spyder 5.4.3 would fail to start and give the error:

/Users/semmett/anaconda3/bin/pythonw: line 3: 62479 Segmentation fault: 11 /Users/semmett/anaconda3/python.app/Contents/MacOS/python “$@”

I deleted that installation and installed anaconda 2023.07.2 today. I created only 1 environment. After the installation, I tried the spyder install (5.4.3). It launched successfully. I tried jupyterlab (3.6.3) and it launched successfully. I then went to a terminal session and executed “conda update conda”. After that update, I went back to anaconda navigator and tried to launch spyder (5.4.3). It FAILED with the error:

/Users/semmett/anaconda3/bin/pythonw: line 3: 62479 Segmentation fault: 11 /Users/semmett/anaconda3/python.app/Contents/MacOS/python “$@”

The installation package for anaconda 2023.07-2 has something that, when an update to that fresh installation occurs, causes spyder to fail.

For me the lesson is “DON"T UPDATE 2023.07-2”!

I deleted the 2023.07-2 installation and reinstalled. Spyder 5.4.3 works fine. I attempted an update to scipy (1.10.1 → 1.11.1) using anaconda navigator. update ended with no errors. Tried to start Spyder 5.4.3. It fails with the same error as reported above.

What is going on?

Sorry, forgot to include:

MacOS 13.5.1.

I’ve used anaconda navigator/spyder for at least 3 years and have always successfully been able to update the various packages with zero issues - until now. Spyder seems to have a dependency that, when certain modules are updated (haven’t figured out which ones yet), Spyder fails with the segmentation fault as shown above.