Problem installing Anaconda

Good morning everyone. I’m having some issues on installing this program. The thing is that I start installing it and it works well until it has to set up the base environment. There, the installation process gets stuck and it doesn’t continue. I don’t know what to do, as I’ve deleted the files (5.8GB) three times, what takes my pc around an hour and then tried to install it again.
Meanwhile, I’m coding on visual studio as I’m working. Might this interfere with the installation?

Update: tried to install after restarting and with VS closed and still doesn’t work

Good morning,

Thank you so much for contacting us, can you please send us more information about the error that you are seeing and the operating system that you are using?

A screenshot or the error message would be very helpful, we are happy to assist you.

Same issue facing.
Just downloaded the latest version : Anaconda3-2024.02-1-Windows-x86_64 on 16-Jun-2024.

The installation process is running from 30min but stuck at

** Extract : _anaconda_depends-2024.02-py311_mkl_1.conda**