My anaconda is completely broken what do I do

I installed and uninstalled multiple times, I think it started with me changing the [base] name in conda so I basically changed config files, tried to fix it with adding path then clean install but nothing changed, tried removing any cache, tried conda config --set changeps1 false but I haven’t succeeded. Every time I try to activate conda it gives me this error. ‘DOSKEY’ is not recognized as an internal or external command,
operable program or batch file.

>>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
  File "C:\Users\person\anaconda3\lib\site-packages\conda\", line 1132, in __call__
    return func(*args, **kwargs)
  File "C:\Users\person\anaconda3\lib\site-packages\conda\cli\", line 94, in main_sourced
    print(activator.execute(), end="")
  File "C:\Users\person\anaconda3\lib\site-packages\conda\", line 171, in execute
    return getattr(self, self.command)()
  File "C:\Users\person\anaconda3\lib\site-packages\conda\", line 143, in activate
    builder_result = self.build_activate(self.env_name_or_prefix)
  File "C:\Users\person\anaconda3\lib\site-packages\conda\", line 304, in build_activate
    return self._build_activate_stack(env_name_or_prefix, False)
  File "C:\Users\person\anaconda3\lib\site-packages\conda\", line 333, in _build_activate_stack
    conda_prompt_modifier = self._prompt_modifier(prefix, conda_default_env)
  File "C:\Users\person\anaconda3\lib\site-packages\conda\", line 671, in _prompt_modifier
    return context.env_prompt.format(
KeyError: 'E'

It doesnt let me add the rest of the error but things actually changed, I got anaconda to work again except that it always shows C:\Users\NAME without any (base), its weird because Its not installed in the C drive anymore, but I did install it with admin privileges to see if I fixed the issues somehow. Anyway, when I make a new environment it works. but the directory never changes, all I see always is C:\Users\NAME which makes it almost unusable


Thank you for contacting us, can you try to launch a cd and send us a screenshot?

We are happy to assist you.

whats a cd? in this case i have tried to enter directories and like I said they are all named the same

Hi again,

Sorry If I didn’t explained everything more detailed, on the command line that you are seeing the C:\Users\NAME please launch these commands:



The first command will position you on the user folder, the second command should show a list of files, please send us a screenshot with that information so that we can assist you better.

In the meantime if you want to try something else you can fully remove Anaconda and then install it again, that should fix errors.

In the meantime we will be waiting for your answer.