MacM2 chip support

I hope you are well.
Does the ARM/M1 Anaconda distribution run on the recently released M2 chipset in new Macbooks? If not, is there a compile from source option possible?
Sorry to be clueless.

1 Like

If something runs natively on the Apple M1 Chips it should run natively on the Apple M2 Chips.

Of course there’s a very small possibility code could hit a weird bug in M2 that it does not hit in M1, but in general this shouldn’t happen.

1 Like

After running the Anaconda3-2022.05-MacOSX-arm64.pkg on a MacBook Pro M2, the installation wizard ran and a bunch of anaconda files were placed in ~/opt, but nothing was added to Launchpad or Applications. What do you run to bring up Anaconda Navigator if no icons were installed anywhere?

Hi @L_F ,

Unfortunately right now we do not have native support for Apple M2 chips for Anaconda Navigator.
However, Apple states they have built in some compatibility with most applications that run natively using the M1, which Navigator does. So here are a few suggestions to try:

You can try opening your Terminal and typing anaconda-navigator and Return to run Navigator. If that does not work, you may want to make sure that it has been installed with your Conda install. To do this, open your Terminal > Type conda list > and hit return. In the list of applications you should see Anaconda Navigator near the top as well as the version that you installed. If you do not then you can install it directly in the terminal by entering conda install anaconda-navigator. Then you can retry opening Navigator. There is an updated version of Navigator (2.2.0) that is available that I would certainly suggest as well.

Thank you!

@jmcallister hello and thanks very much - those steps were really helpful.

Yeah, it seems there was a long list after executing conda list- but no anaconda-navigator for some strange reason… But anyway the command line approach conda install anaconda-navigator worked great, so thanks heaps.

1 Like

Unfortunately, there’s still something very wrong with this Anaconda installation, it failed to install Spyder, complaining about not being there, but qt is installed when checked with conda list.

Upon trying conda install PyQtWebEngine, the resolver just sat there for hours not finding any way forward.

Many people suggest using pip to install it, but many people condemn the use of pip with anaconda. There doesn’t seem to be any official info on what to do.
On Windows the installer just works, but on Mac M2 this is not the case.

I ended up installing miniconda. That worked without a hitch on the M2.

Same thing happened to me regarding install – everything ran smoothly even in the graphical installer (for the M1 distro) but when I went to find Anaconda Distribution it was not there. I followed these steps and got it to work, but all is not well in Anaconda M2 land… I had a heck of a time unraveling the mess that came from migrating Anaconda from my previous (intel-based MBP) laptop. Tried to follow the clean uninstall procedure and it did NOT work. Had to resort to manually removing the opt folder and .bash_profile file completely and then changing the target directory in the graphical installer. Hopefully Anaconda works this out soon.

1 Like

Since this thread started, the Anaconda install on an M2 Mac seems to work, but only sort of. At some point, it appears there were defects in the OSX vecLib and builds started excluding the Accelerate framework. On an Intel based Mac, no problem, you can use atlas. On an M2, the performance of things like SVD is up to 100x slower when openblas is used instead of Accelerate. As a result, the default install of numpy on Mac M2 is pretty useless. Fixing numpy is straightforward, install with pip:

pip install --no-binary :all: --no-use-pep517 numpy

The trouble is all kinds of other components dependent on numpy don’t want to use the pip built numpy; the condo recipes drag in openblas, and crush numpy performance.

Is there an easy way to fix the problems with dependencies?

Also, I understand the problems with Accelerate were fixed in OSX 11.3+. Does anyone know what the supposed problems with vecLib were and how to test for them? I could not find it.