Anaconda Navigator not opening on M2 MacBook Air running MacOS Ventura

I just downloaded anaconda on my M2 MacBook Air running MacOS Ventura (version 13.1.1). The download process went smoothly and I was able to locate Anaconda Navigator. But when I try opening it, it just won’t open without even showing any error message. After trying to run it from the terminal using anaconda-navigator, I got the following error:

I tried to uninstall and reinstall anaconda, I also tried to check the .condarc file I also tried to check the list of packages that were installed using conda list to make sure that anaconda-navigator was there (Version 2.3.1 was installed). I also tried to uninstall and reinstall anaconda navigator using conda remove anaconda-navigator & conda install anaconda-navigator but none of these worked. Is there anyone else experiencing. the same issue? Or does anyone know how to fix that?

Any help would be of great value :grin:

Thank you for your time!


When you did the uninstall, I would try to delete all the Anaconda folders on your system and deleting .condarc and all the files related to conda and do a fresh install.

Hello Krishna,

Since I wasn’t able to find any help online, I had to contact Anaconda on the phone. After a brief phone call with a representative, they told me that Anaconda Navigator does not have any current support for Macs that have the M2 chip. Therefore, I will only be able to use Anaconda through the terminal for the time being.