Issue updating Anaconda, can't open

I tried updating Anaconda, but had some issues. Now cannot open the navigator and get this error any time I try to do anything from the cmd: “PluginError: Error while loading conda plugins from entrypoints: cannot import name ‘ChannelAuthBase’ from ‘conda.plugins.types’ (C:\ProgramData\Anaconda\lib\site-packages\conda\plugins\types.py)”

3 Likes

I’m experiencing the same issue with Anaconda. If you find a solution, please share it. Thank you!

2 Likes

I ended up just uninstalling and reinstalling anaconda, and it ended up resolving the issue

Actually, I still encounter the error. Still not sure what to do

I have exactly the same issue with updating Anaconda on Windows 10

I have the same problem

And it’s not solved with Anaconda reinstall

Facing the same issue

Thank you so much for bringing this issue to our attention we have identified the issue and developed a resolution:

python -m pip uninstall anaconda-cloud-auth
conda update conda
conda install “anaconda-cloud-auth>0.5.0”

If you use Anaconda Navigator:
conda update anaconda-navigator

Thank you so much for bringing this issue to our attention we have identified the issue and developed a resolution:

python -m pip uninstall anaconda-cloud-auth
conda update conda
conda install “anaconda-cloud-auth>0.5.0”

If you use Anaconda Navigator:
conda update anaconda-navigator

python -m pip uninstall anaconda-cloud-auth
conda update conda

Are working fine for me, but when i try to use

conda install “anaconda-cloud-auth>0.5.0”

I get this error:
CondaValueError: You have chosen a non-default solver backend (libmamba) but it was not recognized. Choose one of: classic

I use mamba (with miniconda3), and have also experienced this issue.

Regarding the solution shared by @Saundra_Monroe, I have a similar experience to @adalyn_gibson: The pip uninstall and conda update commands work, but the anaconda-cloud-auth installation step fails.

I tried it with conda and got this:

PackagesNotFoundError: The following packages are not available from current channels:

  - “anaconda-cloud-auth

Current channels:

  - https://conda.anaconda.org/conda-forge/osx-64
  - https://conda.anaconda.org/conda-forge/noarch
  - https://repo.anaconda.com/pkgs/main/osx-64
  - https://repo.anaconda.com/pkgs/main/noarch
  - https://repo.anaconda.com/pkgs/r/osx-64
  - https://repo.anaconda.com/pkgs/r/noarch

To search for alternate channels that may provide the conda package you're
looking for, navigate to

    https://anaconda.org

and use the search bar at the top of the page.

I tried it using mamba, but that just produced warnings about modified cache files, and no action was performed (no errors, though).

I found the 0.5.1 package on conda-forge (despite the conda message above), here: Anaconda Cloud Auth :: Anaconda.org. I tried installing using the instructions there, but with mamba: mamba install conda-forge::anaconda-cloud-auth. It offered to reinstall 0.5.0, which I declined.

I tried that with conda instead of mamba, and it reported that all requested packages are already installed (despite the pip uninstall).

conda also reports:

==> WARNING: A newer version of conda exists. <==
  current version: 23.7.4
  latest version: 24.3.0

Please update conda by running

    $ conda update -n base -c conda-forge conda

Or to minimize the number of packages updated during conda update use

     conda install conda=24.3.0

But when I run conda update -n base -c conda-forge conda, I get “All requested packages already installed.”

Next I tried mamba install "conda-forge::anaconda-cloud-auth>0.5.0" to try to force discovery of 0.5.1. This produced many pages of warnings:

warning  libmamba Problem type not implemented SOLVER_RULE_STRICT_REPO_PRIORITY

then “Could not solve for environment specs” followed by a huge list of incompatible packages, beginning:

The following packages are incompatible
├─ anaconda-cloud-auth >0.5.0  is installable with the potential options
│  ├─ anaconda-cloud-auth 0.5.1 would require
│  │  └─ conda >=23.9.0 , which can be installed;
│  └─ anaconda-cloud-auth 0.5.1 conflicts with any installable versions previously reported;
├─ jpeg is requested and can be installed;
├─ mamba is installable with the potential options
│  ├─ mamba [1.4.4|1.4.5|...|1.5.1] would require
│  │  └─ conda >=4.14,<23.9.0a0  with the potential options
│  │     ├─ conda [23.5.0|23.5.1|...|23.7.4] conflicts with any installable versions previously reported;
│  │     ├─ conda [22.11.1|22.9.0|...|4.14.0] would require
│  │     │  └─ python >=3.10,<3.11.0a0 , which can be installed;
│  │     ├─ conda [22.11.1|22.9.0|...|23.7.4] would require
│  │     │  └─ python >=3.11,<3.12.0a0 , which can be installed;
│  │     ├─ conda [22.9.0|4.10.0|...|4.9.2] would require
│  │     │  └─ python >=3.7,<3.8.0a0 , which can be installed;
│  │     ├─ conda [22.11.1|22.9.0|...|4.9.2] would require
│  │     │  └─ python >=3.8,<3.9.0a0 , which can be installed;
│  │     ├─ conda [22.11.0|22.11.1|...|23.3.1] conflicts with any installable versions previously reported;
│  │     └─ conda 4.14.0 conflicts with any installable versions previously reported;

And so on…

It appears that the offered solution has left my base installation in a pretty bad state. Perhaps this is due to some mamba/conda conflict. I’d appreciate any advice. I’m leaning toward reinstalling, using mambaforge. I recently reinstalled using miniconda, and thus only have ~6 envs I’d have to recreate. But it’s pretty frustrating that a simple “mamba update mamba” led to this mess.

-Tom