Installation problem macOS on M1Pro

Hi, I hope someone can help. I think I’ve made a serious error with an attempt to install Anaconda3 on an M1Pro MacBook running macOS 12.4.

The installer has stopped at the ‘Running Package Scripts’ part of the install with an Installer window prompt saying:’ “Installer” would like to access files in your Downloads folder.’. This window won’t allow me to select either "Don’t Allow’ or “Allow”. All I can do is to press Option + Tab to alternate highlights between the two buttons, but neither button registers when pressed and there’s no way to close the window or proceed. I’ve got confused as to which installer I ran as there are these two in my downloads folder: I think I’ve tried to install the x86-64 version and I should have installed the ARM version for the M1 Mac.


There’s also a .sh file.

What’s my best course of action now? - have I made a serious error by trying to install an incomapible version for my M1 Mac? The installer did say it was checking for compatibility at the beginning and it passed that stage, only hanging towards the end of the install.

Sorry if I’ve done something really stupid, but I would greatly appreciate any advice as how to proceed from this position of being unable to continue with the install or close the Installer. It doesn’t seem like a good idea to force quit the installer close to the end of the install…

I do have a fairly recent Time Machine backup of my Mac, so as a last resort I could revert to that… Do you think that’s necessary - or is there a way to resolve this?

I don’t know if you should use your backup, but I did something similar and evrything worked fine after I uninstalled and reinstalled anaconda.

I am still confused about some things; like what does anaconda being of kind Apple Silicon mean exactly for my packages, and why can I use the navigator even though the blogposts states M1 wont support it yet (it worked both when I installed “wrong” and “right”).

In the end I forced quit the installer. Actually everything appears to have worked with the install as far as I can tell. Anaconda opens, as does terminal and Jupyter Notebook and all seems to be working. I was able to proceed to install the various elements needed for James Webb Space Telescope data, which was the main purpose of my install. (Following instructions here: Getting Started with JWST Data - JWST User Documentation).

The only concern I have is I’m not sure whether I installed the M1 version or the version for earlier Intel Macs. Do you think if I had inadvertently tried to install the wrong version, the install would have proceeded but with errors. The only reason I say that is because Anaconda has crashed a few times since install on a new M1 MacBook. I’m able to restart it with seemingly full functionality.

You mentioned that you had uninstalled Anaconda and reinstalled. How did you uninstall it? Just drag the app to the recycle bin? Does that undo the base root changes and other installs through Anaconda via terminal? Just wanting to get this right and not 100% sure I’ve got the correct version installed for my M1 Pro. How would I check to see. The install alone proved to be quite a steep learning curve! When I press ‘About Anaconda Navigator’ it says v 2.2.0 - it updated to that following the initial install I had problems with.

Any advice gratefully received.

Looking forward to first Webb data on 12 July!

Yes, navigator and jupyter work fine regardless of how you install it - whether the installer is M1 or not, and whether its GUI or console don’t seem to matter.

HOWEVER in my case, only the M1 TERMINAL installer leads to one having the “Apple Silicon” version actually installed. M1 GUI installer installs the “Intel” version.

You can check this by going to Finder>Applications >>> right click on Anaconda Navigador shortcut, select Show Original >>> right click the original executable and select Get Info. Once there, look at the application Kind. Mine used to say Intel with any other install method, but after using M1 terminal installer, it says Apple Silicon which I assume means it is running ‘natively’.

To uninstall if needed, see Uninstalling Anaconda — Anaconda documentation . I recommend doing part B first.

  • Note that if your anaconda3 is in the opt folder (ie you installed for all users), the instructions are a bit misleading because the proper last command is “rm -rf /opt/anaconda3” (rather than “~/opt” as they have it).

  • Note also that ~ stands for /User/username (which is why the prior statement is true).

Thank you - that’s very helpful. I followed your instructions in the last paragraph and it does indeed say “Kind: Application (Intel)”. I think this was my error from probably running the x86_64 dmg instead of the arm64 one (I ended up with both in my downloads!). However, interesting to hear that you only got the Silicon version by installing M1Terminal.

Thanks so much for the uninstall advice (much appreciated). I just went through this process, doing part B first as suggested then part A. I hadn’t installed for all users.

I’m now about to embark on the install process again.
Just to be completely clear in my mind before I embark on this again, are you saying if from the links at the very bottom of Anaconda | Anaconda Distribution, if I install: '64-Bit (M1) Graphical Installer (428MB), it will still be the Intel version even though it says it’s for M1 on the download link? I’d much prefer the GUI, but are you saying that the only current way to get the native M1 version is to install: “64-Bit (M1) Command Line Installer (420MB)”. Am I assuming correctly that you can’t install both versions? Seems so odd that you’ve found the M1 GUI version released in May is still labelled Intel. I wonder what to do for the best with the reinstall. This is all new to me and I’d really like to get the install as good as it can be.

Thanks so much for your help. Please can you advise further on which download I should select for the best. Thanks again.

I decided to opt for the M1 GUI installation on reinstall and I just checked again in Finder and it is now correctly showing as Apple Silicon so it does all work. Thanks so much for your help today, particularly the uninstall instructions! All good now. Much appreciated.

Well that’s good to know because I would have said GUI for M1 link leads to Kind Intel. Did it for me twice, and same for a fellow over at Data Science stackexchange with the same issue.

No idea what’s going on then but glad you got it as Kind Apple Silicon!

PS: the install terminal install is easier than uninstall. I’m a fellow noob at this so I get you. But just fyi it would’ve simply been typing “bash dir/installer”. That opens the file in Terminal and proceeds to ask the same questions as GUI, its just that you have to type “yes” or press enter key as opposed to your mouse :slight_smile:

Also, I’m curious; your navigator works still right? Mine does. I’m confused because 2022.05 blogpost says it should not.

Have you tried removing the previous install of Anaconda from your machine and then try running the ARM installer again?

Sweller: yes, if you see the thread above, that’s exactly what I did and all seems to be fully operational now after a careful uninstall/reinstall using the correct (!) .ARM installer file (and updating to version 2.2.0). All good - definitely my initial error. Following g.rios’ helpful input above, I checked the install and it does now say Apple Silicon. All appears to be fully operational now.

g.Rios: Yes, Navigator all fully operational.

Incidentally, the only thing I’ve found that doesn’t launch is Spyder 5.1.5, but I don’t need that right now and I think it is a known issue (from something I remember reading). In case of interest to anybody reading this, whilst writing about it, here’s what comes up when I try to launch Spyder: (I’ve replaced my personal detail with *** in the paths below).

Traceback (most recent call last): File “/Users//opt/anaconda3/lib/python3.9/site-packages/qtpy/", line 21, in from PyQt5.QtWebEngineWidgets import QWebEnginePage ModuleNotFoundError: No module named ‘PyQt5.QtWebEngineWidgets’ During handling of the above exception, another exception occurred: Traceback (most recent call last): File "/Users//opt/anaconda3/bin/spyder”, line 11, in sys.exit(main()) File “/Users//opt/anaconda3/lib/python3.9/site-packages/spyder/app/", line 233, in main from import mainwindow File "/Users//opt/anaconda3/lib/python3.9/site-packages/spyder/app/”, line 59, in from qtpy import QtWebEngineWidgets # analysis:ignore File “/Users/***/opt/anaconda3/lib/python3.9/site-packages/qtpy/”, line 27, in from PyQt5.QtWebKitWidgets import QWebPage as QWebEnginePage ModuleNotFoundError: No module named 'PyQt5.QtWebKitWidgets

I am still having the issue with the installation on my MacBook Air. I downloaded the 64-Bit (M1) Graphical Installer (428 MB)]. In the last step it is saying “Installation failed” - “The Installation encountered an error that caused the installation to fail. Contact the software manufacturer for assistance”. Can someone please help me with this. thankyou!

My best advice is to try the terminal installer

Dowbload it then open terminal and type “bash directory/installer”. To be clear, replace directory with the real directory and installer with the real name. You can type bash, add a space, then drag the installer to terminal as that will copy over the whole path.

That opens the file in Terminal and proceeds to ask the same questions as GUI, its just that you have to type “yes” or press enter key as opposed to your mouse.

It asks you something after the install which I advice you answer yes to. If you say no, you have to type conda activate on terminal anytime you want to use conda through there. Alternatively if you say yes you have to type conda deactivate anytime you open terminal and want the default status of it.