Anaconda for M1 is kind (Intel) despite using M1 installer

EDIT: I fixed this by using the terminal installer! Seems GUI is bugged? Another difference is I installed in Users/myname/anaconda3/ rather than /opt/anaconda3/

ORIGINAL POST BELOW FOR REFERENCE!

I’ve downloaded the M1 installer, yet Anaconda shows as Application (Intel) rather than Universal or Apple Silicon

This is the only thing I’ve found on this issue conda - New anaconda release for M1 (2022.05) - Data Science Stack Exchange (someone asking the same thing w/ no answers)

PS: Just in case it matters, some caveats. I didn’t actually get asked for Rosetta like the stackexchange post OP did, but I may have just installed it in the past. Another is that right before installing this version I first tried miniforge, failed to access the navigator, then uninstalled. I then proceeded to install Anaconda as I found out about the May 2022 update. However, the default link for Mac is the non-M1 installer and I noticed too late. The install worked, and so did the navigator and Jupyter Lab. However I wanted to ensure I had the most proper version - so again, I uninstalled Anaconda. I then finally proceeded to install Anaconda through the M1 installer, yet the issue persists (although at least now I have navigator).

1 Like