Dependencies: Spyder requires pylint >=2.5.0,<3.1 : 3.1.0

Hi! This is my first post here, if it doesn’t belong here, please let me know!

I get this message when I open Spyder when I open it:

# Mandatory:
pylint >=2.5.0,<3.1 : 3.1.0 (NOK)

I’m using python 3.12 on a virtual environment. With it activated, I uninstalled pylint and installed pylint 3.0.4, but I’m still getting the error message. How can I solve this?

Hello @albma!

Thank you for being an Anaconda User and making your first post on our Anaconda Community Forum!

@Carlos_Valin - woiuld you be able to help out this Community Forum user with their question about why they are getting this error message when they open Spyder?

I would also suggest that you check out this page on Github where there is a similar error message and teh creator of Spyder gives some reasons for it and how you might be able to fix it!


Kim-Anaconda User Care Manager

Great thank you for providing me that information, now let’s try this, the problem may be caused by errors in the Spyder setting and configuration files, we can try to fix it with these instructions:

  1. Close and relaunch Spyder and see if the problem remains.

  2. On the menu, select Start, then select Reset Spyder Settings and see if the problem remains.

  3. Close Spyder and relaunch it from the Anaconda Prompt:

  4. From the Start menu, open the Anaconda Prompt.

  5. At the Anaconda Prompt, enter Spyder.

  6. See if the problem remains.

  7. Delete the directory .spyder2 and then repeat the previous steps from Step 1. Depending on your version of Windows, .spyder2 may be in C:\Documents and Settings\Your_User_Name or in C:\Users\Your_User_Name.

Replace Your_User_Name, with your Windows user name as it appears in the Documents and Settings folder.

  1. Launch in the Anaconda Prompt this command conda update spyder

Please let us know if that fixed your problem and if you need further assistance we are here to help.

Hi! Thanks for replying! I think I know why I get this error: I installed everything directly from the repositories (I’m using Arch Linux):

  • python-pylint 3.1.0-1
  • python-lsp-jsonrpc 1.1.2-1
  • python-lsp-server 1.10.0-1
  • python-pyls-spyder 0.4.0-4
  • python-spyder-kernels 2.4.4-1
  • spyder 5.4.5-1
  • miniconda3 23.10.0-1 (from AUR)

I’ve just tried to install anaconda, but it gave me a compiling error.

:question: I do have a doubt about using miniconda and virtual environments: if I use miniconda to install spyder, how can I use spyder with different virtual environments? Do I have to install spyder in each of them?

Hi again,

We don’t officially support the AUR repository, if you have issues with dependencies you will need to reach out to the package maintainers of those packages, however we do have a guide on how to install Anaconda on Arch: