Data files for Data Visualization Course

Hello. I’m a new Nucleus subscriber. Trying to take the Data Vis course. I can’t find the data filed for the course. A couple of days ago they were in my notebooks files in an Assets folder. That folder and its files are no longer visible and I can’t find a link to re download /upload them. Any tips?
Thanks,
Byron

Hi Byron,

Welcome to the Anaconda Community.

Are you using the Anaconda Notebook Service, or are you downloading the course content to your local machine?

It will also be helpful, if you could attach a screenshot of what you are seeing as you are working through the course…

Thank you.

Hi, thanks for responding.
My intent has been to perform the coursework in the cloud so I can do it mobile. I downloaded and re uploaded the instructor’s second notebook titled something like “2_derive_basic_insight”. I initially had trouble finding the mpg.csv file, then eventually found it in an “assets” folder. Strangely, I can no longer find the assets folder. Probably, I’m doing something ignorant, but after struggling for a couple of hours, I figured I’d ask.
Thanks,
Byron

PS.
They won’t let me add more than 1 picture.

What do you see if you click on the “Folder” icon – in the left-hand panel, just above the one that is selected?

Hi.
Thanks for the help. I finally ended up figuring it out. It seems like my inability to find the asset folder for a while may have had something to do with the launcher getting glitchy and sometimes not opening the folders I was trying to open. When I finally did find that asset folder again I was getting errors on running the notebook with the notebook being on able to find the mpg.CSV File with the path as specified. I tried re-writing the path To make it more accurate, but that also wasn’t working. Finally I ended up just taking all path out of it and just using the name of the file itself, and given that I had moved the notebook into the asset file along with the CSV files, I finally got it to work. I had a bunch of screenshots ready to show all the stuff, but now this probably looks like a pretty boring and pedantic problem that now seems to be fixed. I appreciate folks being so willing to assist me with it, which gives me a good feeling about the nucleus situation going forward. One other minor issue I have found is that I sometimes seem to have trouble getting a lesson to show as having been completed. I’ll fiddle with it some more and see if I can figure it out. Thanks again for the help.
Byron

Hi Byron – no problem, very glad to hear you got there in the end :-). Do let us know if you keep having problems with marking lessons as completed!

1 Like

Thanks again. On the issue with marking sections of the courses as completed, is there a way we are supposed to be turning in our answers to the assigned exercises? If so, that might be the problem, because I haven’t been able to figure out a “turn in” mechanism. I tried doing the exercises on the second section of the course, although admittedly I did not do a great job on them, then cannot figure out whether they are sort of automatically turned in, whether we are supposed to turn them in in some manner, or whether it is just sort of an honor system thing. In any case, when I move on to the third section, I don’t seem to be able to get a checkmark on the second section. Is there anything really obvious that I’m missing or doing wrong? again, I appreciate your time, and apologize if some of these questions are a bit ignorant.
Byron

Hi Byron, Thanks for checking on this, and for taking the data viz course. We measure completion as having viewed the full video for each lesson, if there are quizzes, responded to every quiz question. You do not need to “turn in” any exercises, and we’re measuring only completion, not what you got right or wrong. I don’t think you’re doing anything wrong, and I’ll investigate this further. In the meantime, I’ll go ahead and mark the second section as completed for you.

Hi All!

A related and very beginner question - I used the “upload” button to upload the notebook to my local jupyter lab, and I am getting a FileNotFoundError for assets/mpg.csv - any thoughts on this? Thanks!

1 Like

For anyone struggling with the same thing - I opened the cloud version of labs and it included the Assets folder for the course, I manually downloaded the needed files, and created a local copy of an “assets” folder, and it seems to be working. I might suggest that the assets folder be included with the course to be downloaded along with the notebook for anyone working locally, hope that helps!

1 Like

This might be obvious, but just to recount my success story, in case it helps anyone…
Once I finally found the Assets folder in the Nucleus Jupiter Notebook Cloud, I just uploaded a copy of the relevant instructor notebook into the Assets folder. Then I edited the notebook to take the “Assets” folder part of the file path out of the read_csv command, so that python just finds it in the folder I’m already working out of. I definitely need to get more savvy about managing file paths & directories and so forth, but this is working for now.
Cheers.

Hi again, Jess.
Making slow and intermittent progress, but really enjoying the course. Unfortunately, the issue of the sections not being able to be marked complete has returned. The third section ran very smoothly and was marked complete after I watch the video without any kind of issue. Then after I watched the fourth video I could not get it to mark that section complete, even after multiple attempts to troubleshoot.
Thanks,
Byron