Anaconda installation on linux fails with UnicodeDecodeError

Hi,

I had a few attempts to install either anaconda3 or miniconda3 (just downloaded on 15.11.2022) on openSuse Tumbleweed. I tried it with sh and bash in front of the install script, and in both cases the installer fails after unpacking with a long message which ends in " File “/tmp/build/80754af9/conda-standalone_1636413482883/_h_env_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_p
lacehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placehold_placeho/lib/python3.9/encodings/ascii.py”, line 26, in decode
UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xe7 in position 48: ordinal not in range(128)

My default locale is C (LANG=C and LC_ALL=C), I also tried to set it to UTF-8 following some suggestions. (export LANG=en_US.UTF-8, export LANGUAGE=en_US:en, export LC_ALL=en_US.UTF-8) with no impact. I don’t understand this, but since my default shell is tcsh and I tried this workaround:

After first starting a bash I can run “bash Anaconda3-2022.10-Linux-x86_64.sh” without this particular UnicodeDecodeError. The installer reported a list of packages that it wants to install - but then fails with another error:

"Preparing transaction: done
Executing transaction: -
done
ERROR conda.core.link:_execute(699): An error occurred while installing package ‘defaults::scikit-learn-1.0.2-py39h51133e4_1’.

LinkError: post-link script failed for package defaults::scikit-learn-1.0.2-py39h51133e4_1
location of failed script: /usr/cadtools/anaconda3/bin/.scikit-learn-post-link.sh
==> script messages <==

==> script output <==
stdout:
stderr: /usr/bin/bash: /tmp/_MEIEtD0UR/libreadline.so.8: no version information available (required by /usr/bin/bash)
/usr/bin/bash: /tmp/_MEIEtD0UR/libreadline.so.8: no version information available (required by /usr/bin/bash)
/usr/bin/bash: /tmp/_MEIEtD0UR/libreadline.so.8: no version information available (required by /usr/bin/bash)
/usr/bin/bash: /tmp/_MEIEtD0UR/libreadline.so.8: no version information available (required by /usr/bin/bash)
/usr/bin/bash: symbol lookup error: /usr/bin/bash: undefined symbol: rl_trim_arg_from_keyseq, version READLINE_8.2

return code: 127

()"

How can I get around this? I assume I could somehow remove scikit-learn from the list (how?) and hope to be happy with the rest, or somehow figure out what’s wrong with the libreadline … but that library seems to be part of the installation package as its path is within /tmp/ ?!

thanks
GG

(post deleted by author)

hi, i’m in the same environment (openSuSE Tumbleweed), and just solve the problem.
this script fails to create & write to new file.
“$PREFIX/bin/.scikit-learn-post-link.sh”

echo “some string” >> “$PREFIX/.messages.txt”

(1) touch $PREFIX/.messages.txt
(2) chmod 644 $PREFIX/.messages.txt
(3) rerun install script with u option
ex: ./Anaconda3-2022.10-Linux-x86_64.sh -u