Anaconda install on Win11 fails: Failed to install Anaconda directories

I am running the installation with python deinstaled, antivirus turned off and get this error message.
My OS is Windows 11 (64 bit)

running debug lets me see the following error:
[17584] failed to get the Python codec of the filesystem encoding

Can anyone help?

dear Martina_Gaiser.

Thank you for your contribution to the anaconda community.

This issue is also known for Windows 10 and the solution is documented at the URL below. for your information.

Best regards.

Dear ktsh.tanaka,

I have applied the fix suggested, but still get the same error on install.

dear Martina_Gaiser.

thank you for your reply.

The most common questions about python codec error, regardless of the environment, were the above.

However, I could be wrong too. Because those problems should be shared and solved on python.org.

Therefore, there is a site where the answer is shown about the solution.
It is the following site.

https://bugs.python.org/issue43719

In your case, you may have given the wrong answer because you didn’t indicate the python version.

Best regards.

Dear @ktsh.tanaka.2020,

Thank you for your reply. The conflict is between the latest python release (3.10.7) and the latest anaconda release, which is python 3.9. As the error has been corrected for python 3.10.

I have removed my python 3.10 as well as anaconda and tried to re-install anaconda, but still get the same error. To me it seems that the the fix you have pointed me to has been applied to anaconda which is a python 3.9.12 release.

So I am still stuck …

Kind regards,

Martina Gaiser

Dear Martina_Gaiser.

thank you for your reply

Did you know you can install Python again after installing Anaconda?

https://anaconda.org/anaconda/python

You can access and install Python3.10.4 by logging in to anaconda.org by visiting the site.

Of course it’s not modern Python. The reason is that Anaconda is for commercial users, so updates are applied after verification, so there is a slight time lag.

If you can understand this area, I think Anaconda will be your wonderful partner.

Best regards.

I have the same error
But I ever installed anaconda, after that I reinstalled and I can’t install it again

And now I Format and reinstall windows, but it is still not working
what happens!?