AI Navigator Local Issuer Certificate Error (Windows 10)

AI Navigator fails to launch on Windows 10 with the titular error. I know the solution to the issue is I need to update the SSL certificate being used by the application, but the problem is I cannot find the certificate AI Navigator is using. To be clear, I have an updated certificate which I have used many times with other applications to fix similar errors, but I just don’t know where AI Navigator is storing/searching for its certificate. Been searching the file paths created during installation in AppData folders and so far I have yet to find any .pem or .crt files which are typically the culprits.

Alternatively, is there a configuration file that comes with AI Navigator which would allow me to specify a particular .pem or .crt file or an SSL path for AI Navigator to automatically use at launch? Anaconda Navigator has a similar setting which I currently use.

EDIT: Found a log file which outputs the following:
[2024-07-10 12:34:46.620] [info] Creating main window…
[2024-07-10 12:34:46.740] [info] Checking for update
[2024-07-10 12:34:47.005] [info] Log from renderer process
[2024-07-10 12:34:47.005] [debug] Renderer reloaded!
[2024-07-10 12:34:47.005] [debug] AppLoader status query: LOAD_START
[2024-07-10 12:34:47.039] [debug] Importing hyllama
[2024-07-10 12:34:47.043] [debug] Starting Auth Service…
[2024-07-10 12:34:47.201] [debug] Initializing renderer error handler…
[2024-07-10 12:34:47.201] [debug] Querying logged in user
[2024-07-10 12:34:47.238] [error] Error: unable to get local issuer certificate

Is it this “hyllama” causing the problem? I’m looking through its folders but not seeing any SSL info.

I don’t know the solution to your issue, but I do know there is a folder called .anaconda that contains a navigator folder that contains the configuration files for Navigator. This file is usually hidden on Windows by default - but it is possible to make it visible, and you should be able to also find it from the command prompt or anaconda prompt. That folder contains a navigator.ini file that includes configuration options for Navigator - including SSL. Sometimes removing this folder so it is recreated automatically can fix issues that Navigator is having (getting it out of a stuck state). Another aspect to check is your conda configuration file (.condarc) - sometimes the ssl setting there can also impact Navigator as in many ways it is a GUI for conda. Hope this helps you figure out a solution to the issue you’re running into!

To clarify, this is for AI Navigator, not Anaconda Navigator.

EDIT: Fixed. For anyone needing help, make sure you have a valid SSL certificate file somewhere, like “cacert.pem,” then do the following in a command line:

setx SSL_CERT_FILE “C:\Path\to\cacert.pem”

setx NODE_EXTRA_CA_CERTS “C:\Path\to\cacert.pem”

Evidently, AI Navigator uses these environment variables to find a local issuer certificate and mine were configured incorrectly. You can change these without admin permissions, btw.