SSL Certificate Verification Error when Creating Conda Environment

Hello Anaconda Community,

I’m experiencing an issue with Anaconda when trying to create a new conda environment. I’ve recently installed Anaconda, and I’m running into SSL certificate verification problems that prevent me from creating environments or downloading packages.

Here’s the error message I’m encountering:

CondaSSLError: Encountered an SSL error. Most likely a certificate verification issue.

Exception: HTTPSConnectionPool(host=‘’, port=443): Max retries exceeded with url: /pkgs/main/win-64/current_repodata.json (Caused by SSLError(SSLCertVerificationError(1, ‘[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1129)’)))

I have tried to address this issue by downloading a certifi.pem file and pointing Anaconda to it, but the problem persists.

I’m using Anaconda on a Windows system, and I would appreciate any guidance or suggestions on how to resolve this SSL certificate verification error so that I can create and manage conda environments without issues.

Thank you in advance for your help!


This kind of error message can occur when your company uses a proxy and you need to configure conda to use a proxy.

For issues surrounding, and instructions for, correctly installing SSL Certificate

You can either turn off SSL configuration:
conda config --set ssl_verify false

or add a certificate and let conda know where it is located:

conda config --set ssl_verify <pathToYourFile>.crt

Did you try configuring the SSL cert for conda this way, or some other way?

If you are behind a company proxy, you want to edit the .condarc file as follows(for example):