Unable to launch Anaconda-Navigator after installing Anaconda, and Anaconda Navigator separately on Mac

I installed Anaconda on Mac (Apple silicon installer). Everything goes smoothly. I can also see an Anaconda Navigator icon appear in the applications section. When I click to launch it, it appears momentarily on the Mac Dock, then disappears. I have tried separately installing and updating Anaconda Navigator, but no luck.
I also tried launching Anaconda Navigator from Conda CLI. When i run anaconda-navigator on my conda zsh shell, it returns - zsh: command not found: anaconda-navigator. I think I am doing something fundamentally wrong. PLEASE Help!

Also, when I try to run spyder from my mac terminal, i get this error:-

The available OpenGL surface format was either not version 3.2 or higher or not a Core Profile.

Chromium on macOS will fall back to software rendering in this case.

Hardware acceleration and features such as WebGL will not be available.

fromIccProfile: failed minimal tag size sanity

/opt/anaconda3/bin/pythonw: line 3: 21439 Segmentation fault: 11 /opt/anaconda3/python.app/Contents/MacOS/python “$@”

(shishirgupta83). I was wondering if you were able to resolve your issue? Happy 4th.

Hello there,

Did you first activate the base environment? conda activate base once base is activated then type anaconda-navigator