Spyder Not Launching on Mac m1

Hi! When I tried to launch Spyder, it shows
“Traceback (most recent call last):
File “/Users/zhangyu/opt/anaconda3/bin/spyder”, line 11, in
File “/Users/zhangyu/opt/anaconda3/lib/python3.9/site-packages/spyder/app/start.py”, line 252, in main
from spyder.app import mainwindow
File “/Users/zhangyu/opt/anaconda3/lib/python3.9/site-packages/spyder/app/mainwindow.py”, line 57, in
from qtpy import QtWebEngineWidgets # analysis:ignore
File “/Users/zhangyu/opt/anaconda3/lib/python3.9/site-packages/qtpy/QtWebEngineWidgets.py”, line 28, in
from PyQt5.QtWebEngineWidgets import (
ImportError: dlopen(/Users/zhangyu/opt/anaconda3/lib/python3.9/site-packages/PyQt5/QtWebEngineWidgets.abi3.so, 0x0002): tried: ‘/Users/zhangyu/opt/anaconda3/lib/python3.9/site-packages/PyQt5/QtWebEngineWidgets.abi3.so’ (mach-o file, but is an incompatible architecture (have ‘arm64’, need ‘x86_64’)), ‘/System/Volumes/Preboot/Cryptexes/OS/Users/zhangyu/opt/anaconda3/lib/python3.9/site-packages/PyQt5/QtWebEngineWidgets.abi3.so’ (no such file), ‘/Users/zhangyu/opt/anaconda3/lib/python3.9/site-packages/PyQt5/QtWebEngineWidgets.abi3.so’ (mach-o file, but is an incompatible architecture (have ‘arm64’, need ‘x86_64’))”

What OS are you running on - Mac or Linux?

The error message indicates what the problem is - you are using the wrong installer for your platform. You need the Linux x86_64 installer - it is available from the page:

I would try the command-line installer, if you are using a Mac.

Bonjour, j’ai presque le même problème sur mon Macboook air. Je n’arrive pas à lancer spyder et voici le message qui s’affiche:
Traceback (most recent call last):
File “/Users/ousmane/anaconda3/bin/spyder”, line 7, in
from spyder.app.start import main
File “/Users/ousmane/anaconda3/lib/python3.11/site-packages/spyder/app/start.py”, line 28, in
import random
File “/Users/ousmane/anaconda3/lib/python3.11/random.py”, line 49, in
from math import log as _log, exp as _exp, pi as _pi, e as _e, ceil as _ceil
ImportError: dlopen(/Users/ousmane/anaconda3/lib/python3.11/lib-dynload/math.cpython-311-darwin.so, 0x0002): symbol not found in flat namespace ‘__PyModule_Add’

Bonsoir, quelqu’u peut m’aider s’il vous plait ?