Scripts not Running in Jupyter Notebook


I am calling the Jupyter Notebook on Mac OS from Anaconda Navigator / Terminal. In either cases, the notebook opens in Safari but the Python scripts DO NOT get executed ! (no error message).

I tried to open the notebook in Chrome by modifying the and that did not work either.

I am very confused. Tried to uninstall/reinstall the package. Can someone give me a hint please?

Thanks in advance

Usually, you should be able to see if the kernel is active or not in the top of a Jupyter Notebook page.

Furthermore, do you start Jupyter Notebook from an activated environment? So you first start Anaconda Prompt before typing jupyter notebook ?

I am not a Mac user, so if it comes down to the details I won’t be able to help you further… hopefully someone else can!

@e.rotteveel : Thanks for the response. the Kernel is Python 3 (ipykernel) and is active. I tried to restart it from the Kernel menu but that was not helpful.
In Mac, I did not find an Anaconda Prompt, rather, I called the Jupyter from Terminal. but that did not make any difference.

Hope some Mac users can further help me.