Problem when activating environment

When I activate my python environment it says “WARNING: overwriting environment variables set in the machine overwriting variable [‘PATH’]”. I also notice because of this most of the commands I use within the environment including jupyter notebook doesn’t work. This problem started when I made a mistake while integrating another software which I now successfully have integrated.

Thank you I appreciate anyone who gives feedback and suggestions.

(I’m on windows 10)

I don’t know if this is a bug or not, cause it seems like there’s something wrong with how you had installed it.

Can you show us a screenshot of what you mean, and also the steps to reproduce it?

Thank you for the response.

To reproduce it I open up “Anaconda Prompt” then within the terminal I activate my environment (conda activate bash1pilot) which I called bash1pilot. When it’s activated I can tell there is a problem not just because of the warning message but also because the commands there after don’t work properly such as jupyter notebook which is the program I’m trying to access.

To add to this it was working perfectly until I was trying to integrate a different program but I made a mistake during the integration process which likely lead to this problem. If I had to guess it could be a directory issue. If I were to retrace my steps this is what I remember doing:

conda activate bash1pilot
set PATH=%PATH%;C:\Users\User\Desktop\gmsh-4.11.1-Windows64
then I closed and reopened Anaconda

So, according to this tutorial, what you’re doing is not the correct way of setting environment variable. but instead it should’ve been something like

conda activate bash1pilot
conda env config vars set my_path=C:\Users\User\Desktop\gmsh-4.11.1-Windows64

But it’d have seem like it’d be isolated in the bash1pilot environment when you activate it.

Does the warning also happens when you do the same if use a new environment? Try this way

conda create -p C:\Temp\bash1pilot_temp python ipykernel jupyter -y
conda activate C:\Temp\bash1pilot_temp
cd C:\Temp
jupyter notebook
1 Like

Thank you. The problem occurred because of “set PATH=%PATH%;C:\Users\User\Desktop\gmsh-4.11.1-Windows64” which is something I should avoid and I fixed it by uninstalling and reinstalling everything. The issues no longer persist.

pls i need help everyone, so i just created a new conda environment the version is 23.7.4 so when i try activating the environment with “conda activate ”, i receive this error error: argument COMMAND: invalid choice: ‘activate’ (choose from ‘clean’, ‘compare’, ‘config’, ‘create’, ‘info’, ‘init’, ‘install’, ‘list’, ‘notices’, ‘package’, ‘remove’, ‘uninstall’, ‘rename’, ‘run’, ‘search’, ‘update’, ‘upgrade’, ‘build’, ‘convert’, ‘debug’, ‘develop’, ‘doctor’, ‘index’, ‘inspect’, ‘metapackage’, ‘render’, ‘skeleton’, ‘repo’, ‘env’, ‘content-trust’, ‘token’, ‘verify’, ‘server’, ‘pack’)
i’ve tried every other command like “activate” but nothing seems to work, pls i need help to navigate through this issue, Thanks…