Installing Anaconda, nothing works. Please help ASAP

Hello I have tried everything. I have tried the trouble shooting website, I have tried using install manager, and command line install, and nothing works. I always get an error message that just says install failed, and to contact the company. On line install I got
[/Users/…/anaconda3] >>>

PREFIX=/Users/…/anaconda3

Unpacking payload …

/Users/…/Downloads/Anaconda3-2024.02-1-MacOSX-arm64.sh: line 1228: /Users/…/anaconda3/_conda: Bad CPU type in executable

I no longer have any idea what to do. Is there anybody in Anaconda that can speak to directly? I have already tried IT with my own organization and have gotten nothing. Please help, I need this for school, and really have no other idea of what to do.

Hello jlatch, I’m sorry to hear you’re having a hard time. Based on the error message, can you confirm what kind of Mac (year, etc.) you’re using?I suspect you’re using the installer for new Apple Silicon Macs (most new macs the last few years) but you may be running on an Intel-powered mac.

If you’re not sure which you have, you can run sysctl -n machdep.cpu.brand_string from a terminal to see what kind of processor you have.

  • If the answer starts with “Intel”, use the installer with a name that ends with “-x86_64”.
  • If the answer starts with “Apple” you have the right installer (ending in “-arm64”) and something else is going on, which we can dig into.