Installed succesfully, Navigator not installed

Downloaded the installer from Free Download | Anaconda

Everything installs properly, and it shows as successful. Towards the end of the installation, I kept the box ticked for launching the navigator, but it did not open. I went to the folder/directory where anaconda is installed (C:\Users\devme\anaconda3) and checked there but it seems that anaconda navigator and prompt are not installed. I also tried searching for it using the search bar but it does not exist.

Seeing a youtube video, I went again to the folder where anaconda is installed and then went to the folder “Scripts”, and there I can see a file for anaconda-navigator. However, the logo is not there next to it and there is just a standard logo for applications which is usually not the case. I click on that and then the terminal opens (blank), but after some time this error shows:

And once the error shows, anaconda navigator does open up. But I am not sure that this is viable and will work in the long run. I am also not able to access it using the terminal. What could be the reasons for this problem, is it my system or is there a problem with anaconda?

I had tried uninstalling and re-installing multiple times but it had not worked.
I was able to make it work in the following way:

  1. Uninstall using the uninstaller provided. The folder (anaconda3) that was created will also be removed.
  2. The folder where the original anaconda3 folder was created will also contain some other conda related files that will not be deleted. Delete all these files and folders related to conda. This is crucial.
  3. After all these files are removed. Reinstall anaconda using the installer. Make sure to check the box to remove the cache as well.

Hope this helps someone.