How create new input cell in JupyterLab (macOS)

I’m running anaconda3 under macOS 12.5 on an M1 Mac and am able to start jupyterlab from the conda command line (since anaconda-navigator is not yet available for M1 Macs). I opened the sample notebook “Predicting Pittsburgh Bike-share Rides” and can evaluate the first input cell (with Python 3 ipykernel). But…

Second input cell begins from js import fetch which throws error that there is no such module js. So I want to insert a new input cell to import js.

But I am unable to insert a new input cell: While in Edit mode I tried the documented B key comand, but that just inserts B at the cursor location in the currently selected input cell.

How to proceed?

Added (1): I tried to install the js package from the conda but it finds no such package.

Added (2): From From js import fetch - error I learn that this demo is not meant for local anaconda/conda/python/jupyter-lab use! Instead of the cell with the from js import fetch command, one wants simply:

df = pd.read_csv('')

However, the issue remains: how to insert a new input cell!

1 Like