Geopandas install fails with glibc-version-related UnsatisfiableError on Ubuntu 22.04 Linux

I’m having trouble installing the geopandas package with Anaconda on Linux Ubuntu 22.04. I’m getting an UnsatisfiableError that sounds like it’s saying the package is not compatible with the glibc 2.35 installed as part of Ubuntu.

This is on a relatively new Ubuntu 22.04 VM, with Anaconda3 installed a couple months ago. I’m up to date with all apt update; apt upgrade updates as of last night, 2022-10-27.

The error looks like this:

$ sudo /opt/anaconda3/bin/conda install geopandas
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: |
Found conflicts! Looking for incompatible packages.
This can take several minutes.  Press CTRL-C to abort.
failed
UnsatisfiableError: The following specifications were found to be incompatible with each other:
Output in format: Requested package -> Available versionsThe following specifications were found to be incompatible with your system:
  - feature:/linux-64::__glibc==2.35=0
  - feature:|@/linux-64::__glibc==2.35=0
Your installed version is: 2.35

And if I turn on conda config --set unsatisfiable_hits True, then I get a slightly different looking error:

conda.exceptions.UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versionsThe following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.35=0
  - python=3.9 -> libgcc-ng[version='>=7.5.0'] -> __glibc[version='>=2.17']

Your installed version is: 2.35

Does anyone know what is causing this, what it “means”, and how to fix it?

How do I read that last message that has the two “-” bullet points? Does it mean these are two separate conflicts between packages and my Ubuntu system? Or does it mean that the “feature:/linux-64::__glibc==2.35=0” requirement wasn’t met, and that second line ending in “… __glibc[version=‘>=2.17’]” is the underlying package dependency that caused the conflict indicated by the first line?

And how do I read “__glibc==2.35=0” with those two separate equal-sign runs? Does that mean “__glibc must not be equal to 2.35”? Or is that trailing “=0” some oddly-formatted other thing?

I’m installing geopandas from main, which I think means it’s trying to install geopandas 0.9.0. That’s 14 months old, and the conda-forge geopandas is a much newer 0.12.0. But I’m reluctant to use the conda-forge geopandas package, because it has dependencies on some central numeric libraries, and I’m not prepared to switch all our packages over to conda-forge to be consistent with that.

I’ve been googling around and looking through Stack Overflow, but can’t seem to find anything that actually addresses this.