DLL load failed: impossible to find the specified procedure

Hi, I’m using Jupyter Lab and when I try to import the netCDF4 library, this error occurs:

DLL load failed: impossible to find the specified procedure

So I tried with:

  1. conda remove netCDF4
  2. conda install -c conda-forge netCDF

but the error is still there and when the installation is over there is this sentence:

SafetyError: The package for libzip located at C: \Users\franc\anaconda3\pkgs\libzip-1.8.0-h49b8836_0 appears to be corrupted. The path ‘Library/bin/zip.dll’ has an incorrect size.

reported size: 108032 bytes

actual size: 77824 bytes

ClobberError: The package ‘defaults/win-64::hdf4-4.2.13-h712560f_2’ cannot be installed due to a path collision for ‘library/copying’.

This path already exists in the target prefix, and it won’t be removed by an uninstall action in this transaction. The path is one that conda doesn’t recognize. It may have been created by another package manager.

What can I do?
Thank you very much in advance

Thanks for reaching out, It seems that something went bad in the installation process, let’s try a reinstallation but with a full cleaning process this time:

Full Uninstall

A full uninstall removes all traces of the configuration files and directories from Anaconda and its programs with the anaconda-clean program.

  1. In Windows, open Anaconda Prompt. In Mac or Linux, open your terminal application.
  2. Install the anaconda-clean package:

conda install anaconda-clean

  1. Then, run anaconda-clean. Run the command by itself to remove all Anaconda-related files and directories with a confirmation prompt before deleting each one, or use the --yes argument to remove all those files and directories without being asked to confirm each one.

If you want to confirm each file and directory you are deleting


If you don’t want to be asked about each file and directory

anaconda-clean --yes

  1. anaconda-clean creates a backup of all files and directories that might be removed in a folder named .anaconda_backup in your home directory. Also note that anaconda-clean leaves your data files in the AnacondaProjects directory untouched.
  • After using anaconda-clean, follow the instructions in Simple remove to finish uninstalling Anaconda Distribution.
  1. Open the file explorer.
  2. Delete your environment (anaconda3\envs) and package (anaconda3\pkgs) folders in your user folder.
  3. Open Add or remove programs and uninstall your Anaconda installation or your version of Python.

After that you can reinstall Anaconda again and the problem should be fixed, let us know if it worked, we are eager to help.

Did you try installing the package like this as mentioned in the documentation?

conda install -c conda-forge netCDF4