Anaconda became unusable due to SSL problems

I have been using anaconda for more that a year, until recently I started getting SSL errors and Anaconda became completely unusable for me.

This is the error I get:

CondaSSLError: Encountered an SSL error. Most likely a certificate verification issue.

Exception: [SSL: DECRYPTION_FAILED_OR_BAD_RECORD_MAC] decryption failed or bad record mac (_ssl.c:2580)

It happens when I try to install, package, update anything or sometimes even create a venv. I tried EVERY solution on internet, uninstalled Python and Anaconda completely and reinstalled, disabled SSL verification, switched networks, checked proxies, copied 2 files in anaconda directory (many said this was a solution), etc. NOTHING worked.

There must be an explanation and therefore a solution, but I cannot find it. Please, I beg you conda pros, let me know what is the last thing I can try before I give up?

Same issue here, tried everything (changing firewall, switches, os), nothing helps. It doesn’t occur always… maybe 1 in 100 cases…

1 Like

I had to say goodbye to Anaconda because of it…

Thats to bad… do you encounter SSL errors to other websites/services? And do you also encounter this issue while connecting via mobile hotspot?

Yes, hotspot too. No other service or website results in ssl error for me. I even reset my PC and reinstalled anaconda but same issue persisted.