TypeError: attrs() got an unexpected keyword argument 'eq'

can’t open anaconda navigator. Anaconda Prompt works. I uninstalled and resintalled everything once. I ran updates on both conda and conda navigator but continout to get this error: TypeError: attrs() got an unexpected keyword argument ‘eq’

exactly like this:
(base) C:\Users\joewe>anaconda-navigator
Traceback (most recent call last):
File “C:\Users\joewe\anaconda3\Scripts\anaconda-navigator-script.py”, line 6, in
from anaconda_navigator.app.main import main
File “C:\Users\joewe\anaconda3\Lib\site-packages\anaconda_navigator\app\main.py”, line 19, in
from anaconda_navigator.app.start import start_app
File “C:\Users\joewe\anaconda3\Lib\site-packages\anaconda_navigator\app\start.py”, line 21, in
from anaconda_navigator.config import CONF, LINUX, LOCKFILE, MAC, PIDFILE, UBUNTU
File “C:\Users\joewe\anaconda3\Lib\site-packages\anaconda_navigator\config_init_.py”, line 23, in
from anaconda_navigator.config.main import CONF
File “C:\Users\joewe\anaconda3\Lib\site-packages\anaconda_navigator\config\main.py”, line 18, in
from . import preferences
File “C:\Users\joewe\anaconda3\Lib\site-packages\anaconda_navigator\config\preferences.py”, line 33, in
from . import structures
File “C:\Users\joewe\anaconda3\Lib\site-packages\anaconda_navigator\config\structures.py”, line 33, in
@attr.s(auto_attribs=True, eq=False, frozen=True, slots=True)
TypeError: attrs() got an unexpected keyword argument ‘eq’

1 Like

I got the same error with the 2023 July and Sept Windows installer. Ended up uninstalling attrs and reinstalling it.

  • Open Anaconda Prompt
  • Type “pip uninstall attrs”
  • Type “pip install attrs”

I’m using the 2023 07 installer and that command uninstalled attrs version 18 and installed version 21. Anaconda Navigator then opened up when I clicked on the icon.

Unfortunately, this did not work for me. My error message was slightly different:

@attr.s(auto_attribs=True, cache_hash=True, collect_by_mro=True, frozen=True, order=False)
TypeError: attrs() got an unexpected keyword argument ‘collect_by_mro’

Running the above did this:
Uninstalling attrs-19.3.0

Install: …
ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
josim-tools 1.1.6 requires attrs<20.0.0,>=19.1.0, but you have attrs 23.1.0 which is incompatible.
jupyterlab-server 2.25.1 requires jsonschema>=4.18.0, but you have jsonschema 3.2.0 which is incompatible.
Successfully installed attrs-23.1.0

So I seem to need an older version of attrs.

Sorry I didn’t update my post after I also got issue starting navigator after fixing the attrs, it had a ton of resource reference issues (missing image files). I end up uninstalling Anaconda completely, install miniconda and then navigator on top of it.

1 Like