Trying to connect to Anaconda Cloud from Anaconda Navigator results in 404 error, using Ubuntu

Hi all, I have installed Anaconda on a Ubuntu laptop. Navigator appears to work correctly, but if I click the ‘Connect’ button at top right and select Anaconda Cloud, a browser page opens at the correct place but then immediately goes to a 404 error message. This happens even if I have already logged in to cloud in another browser page. I am guessing I have done something wrong, but I have no way of understanding what. Can anyone advise please? Thanks, Pete.

Good morning,

Can you please try again?

Hi Carlos, thanks for coming back to me. OK I just tried again, and although it seemed to try for a bit longer on the web page, it did eventually come up with ‘404 - Not Found’ again. Thanks for trying :slight_smile: Pete.

Hi again,

Please try again with an incognito browser and confirm if you can reach this website:

Send us a screenshot if the error appears again including the URL

Hi Carlos, thanks again for your help. OK, I’ll need some advice on how to get the window to open as incognito. I know I can open a new window when I have the browser open, but of course when I click connect from Anaconda it opens the browser itself, so I don’t get the opportunity to say I want an incognito window. I have tried to find out how to default Chrome to always open in incognito mode but can’t seem to do it (bearing in mind I am using Ubuntu Linux). Is there a setting I need to change in Anaconda? Thanks again, Pete.

Hi again,

In Ubuntu you can try to change your default browser by searching Default apps on settings and see if the problem persists or delete the cookies and cache of the website, we still would like to see the URL and a screenshot if possible of the 404 error to see if It’s a problem on our end.

OK, I’ve forced it to use Chrome, and have deleted the cache etc. Now, the page seems to hang here:

Other info, my son get’s exactly the same issue on his Windows 10 PC, using Chrome. Don’t know if that helps. Thanks, Pete.

Before I did that, it briefly went here:

and then went to:

Hi Pete,

In Ubuntu we have an alternative, you can use the terminal and these commands as well:

conda install anaconda-client

anconda login

Hi Carlos, OK I am able to log in to using that method, and when I run anaconda navigator it does show me as connected to But if I then try to connect to anaconda cloud, I get the same issue. Thanks again for your help, Pete.