Getoldtweets3 package installation

I want to install getoldtweets3 package on anaconda. This is not available through conda forge.
I also tried downloading the package and on anaconda prompt I tried to upload it using:
anaconda upload package

But is shows that the package does not exist. Please help mee.

1 Like


nice to meet you.

Is it possible to install using the python pip built into anaconda, even if it is not possible with conda forge?
At that time, what you should be careful about is installing in a virtual environment? Or make sure it doesn’t interfere with other packages.


This package is available on website(GetOldTweets3 · PyPI) and has not been verified by Anaconda.

Here is some info on how to proceed to get the package installed:

Conda and pip have historically had difficulties getting along. Pip hasn’t respected Conda’s environment constraints, while Conda has been all too happy to clobber pip-installed software. It’s a mess. Conda 4.6.0 adds preview support for better interoperability. With this interoperability, Conda can use pip-installed packages to satisfy dependencies, and can even remove pip-installed software cleanly and replace them with Conda packages when appropriate. There’s still room for improvement before pip and Conda are hunky-dory BFFs, but we hope this is a good start. This feature is disabled by default right now because it can significantly impact Conda’s performance. If you’d like to try it, you can set this condarc setting:

conda config --set pip_interop_enabled True

So, the way to get PyPI packages into conda (at the time of writing this) seems to be:

pip install <package>

If you want conda to replace the PyPI packages with its own (where possible), just run:

conda update --all

Given that the above setting is made. Conda marks its own channels as higher priority than pip, thus packages will be replaced.