Cannot run anaconda prompt on Windows

I’m very new to conda, and somewhat of a beginner to python.

I’m getting the following error when I attempt to run the Anaconda Prompt:

Program ‘conda.exe’ failed to run: The specified executable is not a valid application for this OS platform.At
C:\Users\scham\anaconda3\shell\condabin\Conda.psm1:72 char:33
+ … eCommand = (& $Env:CONDA_EXE $Env:_CE_M $Env:_CE_CONDA shell.powershe …
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~.
At C:\Users\scham\anaconda3\shell\condabin\Conda.psm1:72 char:13
+ $activateCommand = (& $Env:CONDA_EXE $Env:_CE_M $Env:CE
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ResourceUnavailable: (: ) , ApplicationFailedException
+ FullyQualifiedErrorId : NativeCommandFailed

Invoke-Expression : Cannot bind argument to parameter ‘Command’ because it is null.
At C:\Users\scham\anaconda3\shell\condabin\Conda.psm1:76 char:36
+ Invoke-Expression -Command $activateCommand;
+ CategoryInfo : InvalidData: (: ) [Invoke-Expression], ParameterBindingValidationException
+ FullyQualifiedErrorId : ParameterArgumentValidationErrorNullNotAllowed,Microsoft.PowerShell.Commands.InvokeExpre

(as an FYI, I had to break up some of the text to stop emojis from appearing)

I used the only installer for conda available for Windows, and did not change any of the default options, and the install seemed successful until I got these errors.

I’m not seeing this error online anywhere for conda specifically, and where ever I found it otherwise seemed to be related to using the 32 vs 64 bit - my PC is 64 bit, and that’s the only one available anyway. (and 64 can run 32, regardless)

I only had Python 3.10 before installing conda, and noticed that the installs at the more specific page are under a Python 3.11 header (no mention of 3.11 here but there is one here).

I downloaded and installed 3.11, but I’m still getting the same error when trying to run the Anaconda prompt.

Ah, looks like an uninstall/reinstall fixed it.