Anaconda 2023.03 is causing major problems

Anaconda 2023.03 is causing major problems.
The installation succeeds, but an update using ‘conda update --all’ destroys the entire installation.
I found an instruction on the web that helped me get around the problem, but… Jupyter Notebook can’t find the autopep8 library even though the library is installed. Jupyter extension jupyter_contrib_nbextensions does not work at all.

I tried several times to reinstall the Anaconda 2023.03 version and every time the same problems. In the end, I uninstalled Anaconda and decided to switch to another company’s Python release, which works perfectly.

1 Like

Same. I am a newbie in learning Data Science. I was running the 2022 version. When I downloaded the installer for 2023.03 and tried to install it on the same folder as the previous one, it said it couldn’t proceed as the folder was not empty. Then I uninstalled it and installed 2023.03. Problems like yours started occurring, namely the “using ‘conda update --all’ destroys the entire installation”. Had to uninstall it completely in safe mode and reinstall it. The first step I did after reinstall was to set the solver to libmamba solver using the instructions here. Now it is working fine for me with Python 3.10.10, although I haven’t tried it with Python 3.11.2 yet.

Thanks for the help. With your advice, I got the update to work and python also came to life. Unfortunately, the joy was too early. Jupyter Notebook again announced that it could not find the autopep8 module. On the Internet I found instructions on how to correct the situation. I followed the instructions and restarted my notebook. This time there was an immediate notification about the lack of a widget module. I reinstalled the module and turned on the Notebook. Did not start but gave an error message about the sqlite module! Enough was enough! I removed Anaconda and decided to use other instruments for the time being.

I am very pleased with that other vendor’s python system. However, this Anaconda problem weighed on my mind and I tried several ways to solve the problem. In the end, one was found.
I reinstalled Windows 11. After that, I installed Anaconda and everything worked now.
Apparently, uninstalling the previous version of Anaconda did not delete all the data and those remaining data prevented the installation of the new version. Such an OS reinstallation should not be the only way to install Anaconda.

Hi, we apologies for the errors that you experienced with Anaconda 2023.03, we take your advices seriously and we will work on it to make sure that this will not happen again.

There’s documentation that explains how to uninstall Anaconda properly so that there are no conflicts when a reinstallation is needed, the article that explains this It’s here:

Then you can install Anaconda again following this instructions:

We are working on a new installer that will fix those issues and will add lot of new functionalities, please let us know if you need anything else or if you experience problems again,

For the second time already, I have had to reinstall the entire Windows 11.
The reason was that ‘conda update --all’ which shattered the entire Anaconda installation. ‘anaconda-clean’ is a full zero function after a broken Anaconda. Simply it does not work at all.
Now, third time, I find myself in the same situation again. I installed Anaconda on a clean machine and ran the command ‘conda update --all’. Anaconda installation broke and that ‘anaconda-clean’ doesn’t work at all. I am sorry, but I cannot continue to use such a problematic programme.
Goodbye forever.