Unable to install turbodbc through Anaconda Prompt

I’m running the individual version of Anaconda3 on Windows 10. It installed Python 3.9.12.
When I go to Anaconda Prompt and try to install the turbodbc package it shows a weird error after 1.5 hrs of installation time.

I’ve used the following commands: pip install turbodbc
conda install -c conda-forge turbodbc
But it’s giving the same result

dear Arjun_Menon.

Thank you for your contribution to the anaconda community.

Regarding tubodbc, when I checked pypi, it seems that only the tar.gz file is not provided as a binary.

Therefore, when installing

python setup.py --build
python setup.py --install

I think you need to run Also, in the case of Anaconda, I think there is an installation error because it is not compiled.

Best regards.

When I try to run these commands it shows:

I tried changing to the directory where I downloaded Anaconda and tried again but its showing the same error

dear Arjun_Menon

thank you for your reply.

The cause is in the directory you set.
“C:\Users\Arjun.Menon\setup.py” is interpreted in python’s setup.py as:


To solve this problem, for example


I think that it will be solved if you create a directory and execute it there.

Best regards.